summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2022-03-31 20:32:23 +0200
committerAndrea Manenti2022-03-31 20:32:23 +0200
commitdc983f3e05e9f779dc2486f8d4172c7bec00cad9 (patch)
tree3807691c000e25ef8302befbd1d6de10c76cac91
parenta589b99aec4f4d4b0266a10009a175d85e2cbb1e (diff)
downloadaur-dc983f3e05e9f779dc2486f8d4172c7bec00cad9.tar.gz
Fixed issue with patch
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 2 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9708cdf9cbb..a4e06e15f8f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = sailboot
arch = any
license = GPL
makedepends = python-setuptools
- makedepends = git
depends = python-mpmath
depends = python-pyparsing
depends = sdpb-git
diff --git a/PKGBUILD b/PKGBUILD
index 06b09bdbd8d8..d56b6938af0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@ url='https://gitlab.com/maneandrea/sailboot'
license=('GPL')
depends=('python-mpmath' 'python-pyparsing' 'sdpb-git')
optdepends=('python-gmpy2' 'sagemath' 'scalar_blocks-git')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools')
source=('https://gitlab.com/maneandrea/sailboot/-/archive/v1.0/sailboot-v1.0.tar.gz' 'pyparsing_fix.patch')
sha256sums=('fcac6a42c2220220737d1274ec86afb2a33488737fb2a81d8ec3e8526b272bc7' 'ac4957d25c46651fc3a3341bacc24636bda1026910491e505fe023f00a45f120')
build() {
cd "$pkgname"-v"$pkgver"
- git apply ../pyparsing_fix.patch
+ patch -p1 < ../pyparsing_fix.patch
python setup.py build
}