summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-12-20 16:51:01 +0100
committerAlexander F Rødseth2017-12-20 16:51:01 +0100
commit7f6ef32fd7d923af89c86fa8a155b1e5b7e946fa (patch)
treed1670e0cb10ea56ff1cf52e6930989ea05f69a87
downloadaur-7f6ef32fd7d923af89c86fa8a155b1e5b7e946fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68b93a25fa5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Dec 20 15:50:43 UTC 2017
+pkgbase = sakemake
+ pkgdesc = Simple way to build your C++17 executables on Linux
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/xyproto/sakemake
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = make
+ depends = scons
+ depends = clang
+ depends = gcc
+ depends = pkg-config
+ source = git+https://github.com/xyproto/sakemake#tag=0.4
+ md5sums = SKIP
+
+pkgname = sakemake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f3662df7a44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=sakemake
+pkgver=0.4
+pkgrel=1
+pkgdesc='Simple way to build your C++17 executables on Linux'
+arch=('x86_64')
+url='https://github.com/xyproto/sakemake'
+license=('MIT')
+makedepends=('git')
+depends=('make' 'scons' 'clang' 'gcc' 'pkg-config')
+source=("git+https://github.com/xyproto/sakemake#tag=$pkgver")
+md5sums=('SKIP')
+
+package() {
+ PREFIX="$pkgdir" make -C $pkgname install
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: