summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUnix Sheikh2019-04-05 07:35:20 +0200
committerUnix Sheikh2019-04-05 07:35:20 +0200
commit7f303698b4567c37ad90b97c812b1aa51097fbcc (patch)
tree7da6560bf6e7d70fa701781f7860bd0ca7dd8653
downloadaur-7f303698b4567c37ad90b97c812b1aa51097fbcc.tar.gz
Initial submission to AUR
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae2dfe67a8ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = salahtime
+ pkgdesc = A small C program for displaying the Islamic prayer time for Copenhagen in Denmark
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/unixsheikh/salahtime
+ arch = any
+ license = The Unlicense
+ source = https://github.com/unixsheikh/salahtime/archive/1.0.0.zip
+ md5sums = c011e5eb216961d7f71579612c2adec9
+
+pkgname = salahtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d67511591d73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Unix Sheikh <unixsheikh at protonmail dot com>
+
+pkgname=salahtime
+pkgver=1.0.0
+pkgrel=1
+url="https://github.com/unixsheikh/salahtime"
+pkgdesc="A small C program for displaying the Islamic prayer time for Copenhagen in Denmark"
+arch=('any')
+license=('The Unlicense')
+
+source=("https://github.com/unixsheikh/salahtime/archive/1.0.0.zip")
+md5sums=('c011e5eb216961d7f71579612c2adec9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make CC=gcc
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "salahtime" "$pkgdir/usr/bin/salahtime"
+ gzip salahtime.1
+ install -Dm755 "salahtime.1.gz" "$pkgdir/usr/share/man/man1/salahtime.1.gz"
+}