summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-22 15:23:56 +0800
committerzxp198210052024-01-22 15:23:56 +0800
commitaa48e7dac84687ec6b1cbf2ba8d540c0b9585df2 (patch)
treef0e77a1169926c25250715491e55e5b3e8122d5f
parentb35754ee017ece09a95267b77a29454bd9d93314 (diff)
downloadaur-aa48e7dac84687ec6b1cbf2ba8d540c0b9585df2.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--salesforce2sql.sh13
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 295fcea2047b..8fdd78b75553 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = salesforce2sql-bin
pkgdesc = Electron app to convert a Salesforce org's schema into a similarly shaped database.
pkgver = 0.9.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/acrosman/Salesforce2Sql
arch = x86_64
license = MIT
@@ -14,6 +14,6 @@ pkgbase = salesforce2sql-bin
source = salesforce2sql-0.9.0.rpm::https://github.com/acrosman/Salesforce2Sql/releases/download/v0.9.0/salesforce2sql-0.9.0-1.x86_64.rpm
source = salesforce2sql.sh
sha256sums = 54691aea18d09b8681fba38a568960673cea0011a1c1cfc3a378a72cb3babcd4
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = salesforce2sql-bin
diff --git a/PKGBUILD b/PKGBUILD
index 20acc3681847..5a12ce6fc102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=salesforce2sql-bin
pkgver=0.9.0
_electronversion=22
-pkgrel=5
+pkgrel=6
pkgdesc="Electron app to convert a Salesforce org's schema into a similarly shaped database."
arch=('x86_64')
url="https://github.com/acrosman/Salesforce2Sql"
@@ -20,13 +20,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('54691aea18d09b8681fba38a568960673cea0011a1c1cfc3a378a72cb3babcd4'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- sed "s|%U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
sed -e '59d' -e'12,16d' -i "${srcdir}/usr/lib/${pkgname%-bin}/resources/app/main.js"
}
package() {
diff --git a/salesforce2sql.sh b/salesforce2sql.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/salesforce2sql.sh
+++ b/salesforce2sql.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file