summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-04 14:01:11 +0800
committerzxp198210052023-06-04 14:01:11 +0800
commitf1c39ce5ede1a576b6785c9086c946239f22cc2f (patch)
tree531b1cd9b98d96a2dcf2bd2be3ed922be6e02bd8
downloadaur-f1c39ce5ede1a576b6785c9086c946239f22cc2f.tar.gz
first release
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD21
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65795717c19c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = salesforce2sql-bin
+ pkgdesc = Electron app to convert a Salesforce org's schema into a similarly shaped database.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/acrosman/Salesforce2Sql
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = alsa-lib
+ depends = libxcb
+ depends = nss
+ depends = libdrm
+ depends = libxrandr
+ depends = at-spi2-core
+ depends = bash
+ depends = pango
+ depends = nodejs
+ depends = make
+ depends = libxfixes
+ depends = expat
+ depends = libxcomposite
+ depends = libxext
+ depends = cairo
+ depends = dbus
+ depends = python
+ depends = glib2
+ depends = glibc
+ depends = libxkbcommon
+ depends = gcc-libs
+ depends = libx11
+ depends = libcups
+ depends = libxdamage
+ depends = mesa
+ depends = nspr
+ depends = python-setuptools
+ conflicts = salesforce2sql
+ source = salesforce2sql-0.9.0.rpm::https://github.com/acrosman/Salesforce2Sql/releases/download/v0.9.0/salesforce2sql-0.9.0-1.x86_64.rpm
+ sha256sums = 54691aea18d09b8681fba38a568960673cea0011a1c1cfc3a378a72cb3babcd4
+
+pkgname = salesforce2sql-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..732499bb9027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=salesforce2sql-bin
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Electron app to convert a Salesforce org's schema into a similarly shaped database."
+arch=('x86_64')
+url="https://github.com/acrosman/Salesforce2Sql"
+license=('MIT')
+depends=('gtk3' 'alsa-lib' 'libxcb' 'nss' 'libdrm' 'libxrandr' 'at-spi2-core' 'bash' 'pango' 'nodejs' 'make' 'libxfixes' 'expat' 'libxcomposite' \
+ 'libxext' 'cairo' 'dbus' 'python' 'glib2' 'glibc' 'libxkbcommon' 'gcc-libs' 'libx11' 'libcups' 'libxdamage' 'mesa' 'nspr' 'python-setuptools')
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.rpm::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-1.${CARCH}.rpm")
+sha256sums=('54691aea18d09b8681fba38a568960673cea0011a1c1cfc3a378a72cb3babcd4')
+
+package() {
+ install -Dm755 -d "${pkgdir}/opt" "${pkgdir}/usr"
+ cp -r "${srcdir}/usr/lib/${pkgname%-bin}" "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/usr/share" "${pkgdir}/usr"
+ sed "s|Exec=${pkgname%-bin}|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file