summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2016-11-21 15:45:52 +1100
committerLiam Greenough2016-11-21 15:45:52 +1100
commit7e076f0570555888c01ffa9d7fed632cd9d7b357 (patch)
treed907ca0fb91dfece0882a9a94652c2cc155b0576
downloadaur-7e076f0570555888c01ffa9d7fed632cd9d7b357.tar.gz
Initial (and hopefully final) commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efcbb37abb74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = salientia-git
+ pkgdesc = Recursive dependency-traversing batch-engraver for GNU Lilypond
+ pkgver = _
+ pkgrel = 1
+ url = https://github.com/Beacon515L/salientia
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = lilypond
+ provides = salientia
+ conflicts = salientia
+ source = git+https://github.com/Beacon515L/salientia.git
+ md5sums = SKIP
+
+pkgname = salientia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b252bbeb00db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+
+# Maintainer: Liam Greenough <beacon515@gmail.com>
+
+pkgname=salientia-git
+pkgver=_
+pkgrel=1
+pkgdesc="Recursive dependency-traversing batch-engraver for GNU Lilypond"
+arch=('i686' 'x86_64')
+url="https://github.com/Beacon515L/salientia"
+license=('GPL')
+depends=('lilypond')
+makedepends=('cmake')
+provides=('salientia')
+conflicts=('salientia')
+source=('git+https://github.com/Beacon515L/salientia.git')
+md5sums=('SKIP')
+
+build() {
+ cd salientia
+ cmake .
+ make
+ }
+
+package(){
+ mkdir $pkgdir/usr $pkgdir/usr/bin
+ cp $srcdir/salientia/salientia $pkgdir/usr/bin/
+ chmod 755 $pkgdir/usr/bin/salientia
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}