summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-08-31 03:18:14 -0300
committerThiago L. A. Miller2018-08-31 03:22:37 -0300
commit098aaca85b2c1cc4c3265169c329d8e95c7adafe (patch)
treeac7c4df7fc80f26b7f0d4d3a46b83bf8b62c9436
parent62c947c3e118b967a386654ba9728b65083450e8 (diff)
downloadaur-098aaca85b2c1cc4c3265169c329d8e95c7adafe.tar.gz
Function prepare() is cleaner
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b11688b49df..7da3eaad381e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = salmon
pkgdesc = Highly-accurate & wicked fast transcript-level quantification from RNA-seq reads using lightweight alignments
pkgver = 0.11.3
- pkgrel = 1
+ pkgrel = 2
url = https://combine-lab.github.io/salmon/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 7e745440ab1e..d6ad2de4ec7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
pkgname=salmon
pkgver=0.11.3
-pkgrel=1
+pkgrel=2
pkgdesc="Highly-accurate & wicked fast transcript-level quantification from RNA-seq reads using lightweight alignments"
arch=('x86_64')
url="https://combine-lab.github.io/$pkgname/"
@@ -13,10 +13,10 @@ source=("$pkgname-$pkgver.tar.gz"::"https://github.com/COMBINE-lab/$pkgname/arch
md5sums=('99e95233be7f8510bed5c4d0c46a5074')
prepare() {
- # Fix for now JEMalloc seg fault when using jemalloc package
- # Force cmake to statically build JEMalloc from salmon's dev sources
- cd "$pkgname-$pkgver"
- sed -i '/^find_package(Jemalloc)/,/^endif()/s/\(.\+\)/#\1/' CMakeLists.txt
+ # Fix for now segmentation fault when using archlinux jemalloc package
+ # Force cmake to statically build jemalloc from salmon's dev sources
+ cd "$pkgname-$pkgver"
+ sed -i '/^find_package(Jemalloc)/ , /^endif()/ s/^/#/' CMakeLists.txt
}
build() {