summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaulius Lukauskas2020-10-20 15:09:46 +0200
committersaulius Lukauskas2020-10-20 15:09:46 +0200
commit0d364991c319423c28c449c55044d59ded44c93d (patch)
treef97de7815a5daf5627dc0c3bb49aca89cddfd578
parent8808ada8835ae23a1e63b521cc5c45e4c5d9e8b4 (diff)
downloadaur-0d364991c319423c28c449c55044d59ded44c93d.tar.gz
updated to 1.3.0
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6aa4f9807e4a..024f5725b76d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
+# Maintainer: Saulius Lukauskas <luksaulius@gmail.com>
pkgname=salmon
-pkgver=0.13.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="Highly-accurate & wicked fast transcript-level quantification from RNA-seq reads using lightweight alignments"
arch=('x86_64')
@@ -10,22 +10,29 @@ depends=('bzip2' 'intel-tbb' 'xz')
makedepends=('boost>=1.55' 'cmake' 'unzip')
options=('!emptydirs')
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/COMBINE-lab/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('bae03f0e2b30d976029f83e745a3ad65')
+md5sums=('ec4fc93d95bbcc782d63578e8f2624fd')
prepare() {
- # Fix for now segmentation fault when using archlinux jemalloc package
- # Force cmake to statically build jemalloc from salmon's dev sources
cd "$pkgname-$pkgver"
- sed -i '/^find_package(Jemalloc)/ , /^endif()/ s/^/#/' CMakeLists.txt
+
+ # Add missing include <string> in 1.3.0 headers
+ sed -i 's/#include <unordered_map>/#include <unordered_map>\n#include <string>/g' include/BAMUtils.hpp
}
build() {
+
cd "$pkgname-$pkgver"
+
+ # FIXME: NO_IPO=TRUE is for some reason needed in 1.3.0
+ # Otherwise it is segfaulting...
+
cmake \
+ -DNO_IPO:BOOL='TRUE' \
-DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-Wno-dev \
.
+
make
}