summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2017-03-03 20:51:36 +0100
committerMichele Mocciola2017-03-03 20:51:36 +0100
commit64fb4e4bfe00b012b0d5075097cde791cc6bcae7 (patch)
tree0c8b9752b88446f5b0578c29d03073da316cb76d
parenta7235c491f8cf9bab6fb677f1c05f59c1b8b80e4 (diff)
downloadaur-64fb4e4bfe00b012b0d5075097cde791cc6bcae7.tar.gz
Updated to sip-4.19 and mesa-17.0.0
-rw-r--r--PKGBUILD13
-rw-r--r--sip-4.19.patch39
2 files changed, 49 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c9950011a3f..f70468168644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=salome-gui
pkgver=7.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="Generic platform for Pre and Post-Processing for numerical simulation - GUI Module"
url="http://www.salome-platform.org"
-depends=("salome-kernel>=${pkgver}" "salome-kernel<${pkgver:0:2}$((${pkgver:2:1}+1)).0" "qt4" "python2-pyqt4" "opencascade>=6.9.0" "qwt" "paraview-salome=5.0.1p1" "sip")
+depends=("salome-kernel>=${pkgver}" "salome-kernel<${pkgver:0:2}$((${pkgver:2:1}+1)).0" "qt4" "python2-pyqt4" "opencascade>=6.9.0" "qwt" "paraview-salome=5.0.1p1" "sip>=4.19.0" "mesa>=17.0.0")
makedepends=('doxygen' 'swig2' 'boost' 'optipng' 'python2-sphinx')
arch=('i686' 'x86_64')
conflicts=()
provides=()
license=('LGPL')
-source=("${pkgname}.sh" "salome.desktop" "http://files.salome-platform.org/Salome/Salome${pkgver}/src${pkgver}.tar.gz")
+source=("${pkgname}.sh" "salome.desktop" "sip-4.19.patch" "http://files.salome-platform.org/Salome/Salome${pkgver}/src${pkgver}.tar.gz")
_source=GUI_SRC
#_source=gui
@@ -55,6 +55,9 @@ prepare(){
do
sed -e "s|python -c|python2 -c|" -i ${_FILE}
done
+
+ # patch for sip-4.19
+ patch -Np1 -i "${srcdir}/sip-4.19.patch"
}
build() {
@@ -75,6 +78,9 @@ build() {
cmake_options+=" -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF"
cmake_options+=" -DSALOME_CMAKE_DEBUG:BOOL=OFF"
+ # opengl: location of libGL.so
+ cmake_options+=" -DOPENGL_gl_LIBRARY=/usr/lib/mesa/libGL.so"
+
# python2
cmake_options+=" -DPYTHON_EXECUTABLE=/usr/bin/python2"
@@ -146,4 +152,5 @@ package() {
}
md5sums=('fd7abc074e23a95ed3dabe841faa7586'
'a102063b779e332914ef0b73843e928a'
+ '9f7b52a2a332681cdd90bf3094dd1ed7'
'0f6de10ad9d9c646fce3ca21a7dab46a')
diff --git a/sip-4.19.patch b/sip-4.19.patch
new file mode 100644
index 000000000000..b48199dd0723
--- /dev/null
+++ b/sip-4.19.patch
@@ -0,0 +1,39 @@
+diff -Naur GUI_SRC.orig/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx
+--- GUI_SRC.orig/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx 2017-03-03 19:31:57.004880382 +0100
++++ GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx 2017-03-03 19:35:09.131684278 +0100
+@@ -1813,7 +1813,7 @@
+ #if SIP_VERSION < 0x040800
+ PyObjWrapper pyws( sipBuildResult( 0, "M", aWorkspace, sipClass_QWidget) );
+ #else
+- PyObjWrapper pyws( sipBuildResult( 0, "D", aWorkspace, sipType_QWidget , NULL) );
++ PyObjWrapper pyws( sipBuildResult( 0, "D", aWorkspace, sipFindType("QWidget") , NULL) );
+ #endif
+ // ... and finally call Python module's setWorkSpace() method (obsolete)
+ if ( PyObject_HasAttrString( myPyModule, (char*)"setWorkSpace" ) ) {
+@@ -2264,7 +2264,7 @@
+ #if SIP_VERSION < 0x040800
+ PyObjWrapper sipPopup( sipBuildResult( 0, "M", menu, sipClass_QMenu ) );
+ #else
+- PyObjWrapper sipPopup( sipBuildResult( 0, "D", menu, sipType_QMenu, NULL ) );
++ PyObjWrapper sipPopup( sipBuildResult( 0, "D", menu, sipFindType("QMenu"), NULL ) );
+ #endif
+
+ // then call Python module's createPopupMenu() method (for new modules)
+@@ -2475,7 +2475,7 @@
+ #if SIP_VERSION < 0x040800
+ PyObjWrapper sipList( sipBuildResult( 0, "M", theList, sipClass_QStringList ) );
+ #else
+- PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipType_QStringList, NULL ) );
++ PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipFindType("QStringList"), NULL ) );
+ #endif
+ if ( PyObject_HasAttrString(myPyModule , (char*)"openFiles") ) {
+ PyObjWrapper res( PyObject_CallMethod( myPyModule, (char*)"openFiles",
+@@ -2629,7 +2629,7 @@
+ #if SIP_VERSION < 0x040800
+ PyObjWrapper sipList( sipBuildResult( 0, "M", theList, sipClass_QStringList) );
+ #else
+- PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipType_QStringList, NULL) );
++ PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipFindType("QStringList"), NULL) );
+ #endif
+ if ( PyObject_HasAttrString(myPyModule, (char*)"dropObjects") ) {
+ PyObjWrapper res( PyObject_CallMethod( myPyModule, (char*)"dropObjects", (char*)"Osii",