summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Johnson2015-07-09 10:22:55 -0500
committerErik Johnson2015-07-09 10:22:55 -0500
commitb0bada16ae8ea6c4b9de44fbb13ad08faf15daba (patch)
treea5357f239fbfdf7588229a1634f60246085bb097
downloadaur-b0bada16ae8ea6c4b9de44fbb13ad08faf15daba.tar.gz
Initial import (still out-of-date, will update)
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD73
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..920cb9aba0e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = salt-git
+ pkgdesc = A remote execution and communication system built on zeromq
+ pkgver = v0.14.0.573.ge6e0ad7
+ pkgrel = 1
+ url = https://github.com/saltstack/salt
+ arch = any
+ license = APACHE
+ makedepends = git
+ depends = python2
+ depends = python2-yaml
+ depends = python2-jinja
+ depends = python2-pyzmq
+ depends = python2-crypto
+ depends = python2-psutil
+ depends = python2-msgpack
+ depends = python2-m2crypto
+ provides = salt
+ conflicts = salt
+ backup = etc/salt/master
+ backup = etc/salt/minion
+ source = git://github.com/saltstack/salt.git
+ md5sums = SKIP
+
+pkgname = salt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5717aae9f44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Christer Edwards <christer.edwards@gmail.com>
+pkgname=salt-git
+_gitname="salt"
+pkgver=v0.14.0.573.ge6e0ad7
+pkgrel=1
+pkgdesc="A remote execution and communication system built on zeromq"
+arch=('any')
+url="https://github.com/saltstack/salt"
+license=('APACHE')
+groups=()
+depends=('python2'
+ 'python2-yaml'
+ 'python2-jinja'
+ 'python2-pyzmq'
+ 'python2-crypto'
+ 'python2-psutil'
+ 'python2-msgpack'
+ 'python2-m2crypto')
+
+backup=('etc/salt/master'
+ 'etc/salt/minion')
+
+makedepends=('git')
+conflicts=('salt')
+provides=('salt')
+
+# makepkg 4.1 knows about git and will pull main branch
+source=("git://github.com/saltstack/salt.git")
+
+# makepkg knows it's a git repo because the url starts with 'git'
+# it then knows to checkout the branch upon cloning, expediating versioning.
+#branch="develop"
+#source=("git://github.com/saltstack/salt.git#branch=$branch")
+
+# makepkg also knows about tags
+#tags="v0.14.1"
+#source=("git://github.com/saltstack/salt.git#tag=$tag")
+
+# because the sources are not static, skip checksums
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git describe --always | sed 's/-/./g')
+ # for git, if the repo has no tags, comment out the above and uncomment the next line:
+ #echo "0.$(git rev-list --count $branch).$(git describe --always)"
+ # This will give you a count of the total commits and the hash of the commit you are on.
+ # Useful if you're making a repository with git packages so that they can have sequential
+ # version numbers. (Else a pacman -Syu may not update the package)
+}
+
+#build() {
+# cd "${srcdir}/${_gitname}"
+# python2 setup.py build
+ # no need to build setup.py install will do this
+#}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ python2 setup.py install --root=${pkgdir}/ --optimize=1
+
+ install -Dm644 ${srcdir}/salt/pkg/arch/salt-master.service ${pkgdir}/usr/lib/systemd/system/salt-master.service
+ install -Dm644 ${srcdir}/salt/pkg/arch/salt-syndic.service ${pkgdir}/usr/lib/systemd/system/salt-syndic.service
+ install -Dm644 ${srcdir}/salt/pkg/arch/salt-minion.service ${pkgdir}/usr/lib/systemd/system/salt-minion.service
+
+ mkdir -p ${pkgdir}/etc/salt/
+ cp ${srcdir}/salt/conf/master ${pkgdir}/etc/salt/
+ cp ${srcdir}/salt/conf/minion ${pkgdir}/etc/salt/
+
+ # remove vcs leftovers
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}