summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Goncharov2020-01-22 18:22:16 +0300
committerzer0def2020-01-22 18:17:45 +0100
commit903b44abed79cb1df80a3f9f008cd778e4768dd6 (patch)
treea3de0ec402519662b9c03524773e4a97f482925d
parentaf1ad2b1ccfc829a0c9315873c78af48bdb4c4db (diff)
downloadaur-903b44abed79cb1df80a3f9f008cd778e4768dd6.tar.gz
Add python3.8 patch for salt-ssh
-rw-r--r--.SRCINFO4
-rw-r--r--0001-saltssh-py38.patch25
-rw-r--r--PKGBUILD14
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e11581924778..70ba56db377f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = salt-py3
pkgdesc = Central system and configuration manager
pkgver = 2019.2.3
- pkgrel = 1
+ pkgrel = 2
url = http://saltstack.org/
install = salt.install
arch = any
@@ -30,8 +30,10 @@ pkgbase = salt-py3
backup = etc/salt/minion
source = https://pypi.io/packages/source/s/salt/salt-2019.2.3.tar.gz
source = salt.logrotate
+ source = 0001-saltssh-py38.patch
sha256sums = 7497e7dbfd4dc3799bbbc8da63da98b8301bbb644150f3905fe5775a7d81271a
sha256sums = abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215
+ sha256sums = e91791b6431ba56ff5ba0b0ff4ae1fba7335fa358698e12829daf2c248c1568d
pkgname = salt-py3
diff --git a/0001-saltssh-py38.patch b/0001-saltssh-py38.patch
new file mode 100644
index 000000000000..e099a04a5962
--- /dev/null
+++ b/0001-saltssh-py38.patch
@@ -0,0 +1,25 @@
+index a3be0b8a1c..ff548923f4 100644
+--- "a/salt/grains/core.py"
++++ "b/salt/grains/core.py"
+@@ -35,12 +35,6 @@ except ImportError:
+ __proxyenabled__ = ['*']
+ __FQDN__ = None
+
+-# Extend the default list of supported distros. This will be used for the
+-# /etc/DISTRO-release checking that is part of linux_distribution()
+-from platform import _supported_dists
+-_supported_dists += ('arch', 'mageia', 'meego', 'vmware', 'bluewhite64',
+- 'slamd64', 'ovs', 'system', 'mint', 'oracle', 'void')
+-
+ # linux_distribution deprecated in py3.7
+ try:
+ from platform import linux_distribution as _deprecated_linux_distribution
+@@ -1939,7 +1933,7 @@ def os_data():
+ )
+ (osname, osrelease, oscodename) = \
+ [x.strip('"').strip("'") for x in
+- linux_distribution(supported_dists=_supported_dists)]
++ linux_distribution()]
+ # Try to assign these three names based on the lsb info, they tend to
+ # be more accurate than what python gets from /etc/DISTRO-release.
+ # It's worth noting that Ubuntu has patched their Python distribution
diff --git a/PKGBUILD b/PKGBUILD
index 03ebce136d9f..28c8cea7e3f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: zer0def <zer0def@github>
+# Contributor: Kirill Goncharov <kdgoncharov cat gmail dog com>
# Contributor: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: SĂ©bastien Luttringer
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
@@ -6,7 +7,7 @@
pkgname=salt-py3
pkgver=2019.2.3
-pkgrel=1
+pkgrel=2
pkgdesc='Central system and configuration manager'
arch=('any')
@@ -36,10 +37,17 @@ backup=('etc/logrotate.d/salt'
install=salt.install
source=("https://pypi.io/packages/source/s/salt/salt-$pkgver.tar.gz"
- salt.logrotate)
+ salt.logrotate
+ "0001-saltssh-py38.patch")
sha256sums=('7497e7dbfd4dc3799bbbc8da63da98b8301bbb644150f3905fe5775a7d81271a'
- 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215')
+ 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215'
+ 'e91791b6431ba56ff5ba0b0ff4ae1fba7335fa358698e12829daf2c248c1568d')
+
+prepare() {
+ cd salt-$pkgver
+ patch -p1 < ../0001-saltssh-py38.patch
+}
build() {
cd salt-$pkgver