summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaloniamatteo2021-03-07 09:15:01 +0100
committersaloniamatteo2021-03-07 09:15:01 +0100
commit01c18eb14fed171bfef725d3584310018d97ee54 (patch)
tree2c87b9a4febf8a9109bf6ed920cfa28bbd045f14
parentc11ff84b3db3587950b6dbe1d468da01117ae1f9 (diff)
downloadaur-01c18eb14fed171bfef725d3584310018d97ee54.tar.gz
Add pkgver(); Add support for 9wm
-rw-r--r--.SRCINFO12
-rw-r--r--9wm.desktop8
-rw-r--r--9wm.pngbin0 -> 4993 bytes
-rw-r--r--PKGBUILD51
-rw-r--r--dwm-9wm.diff61
-rw-r--r--dwm-lightdm.diff18
-rw-r--r--dwm-vue.diff14
7 files changed, 108 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5135f66e4af..0e432360f78f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = saluto-lightdm-theme-dwm
- pkgdesc = Saluto: Litarvan LightDM Theme Fork, with added support for DWM
+ pkgdesc = Saluto: Litarvan LightDM Theme Fork, with added support for DWM and 9wm
pkgver = 3.0.0
pkgrel = 1
url = https://github.com/Demonstrandum/Saluto
@@ -13,15 +13,17 @@ pkgbase = saluto-lightdm-theme-dwm
conflicts = saluto-lightdm-theme
conflicts = saluto-lightdm-theme-git
source = git+https://github.com/Demonstrandum/Saluto
+ source = dwm-9wm.diff
source = dwm.desktop
- source = dwm-lightdm.diff
- source = dwm-vue.diff
+ source = 9wm.desktop
source = dwm.png
+ source = 9wm.png
md5sums = SKIP
+ md5sums = 14d9664d047ee55374b9cdf3aaba4e64
md5sums = 4b077e28d1dcde5ead555d6f433da37b
- md5sums = 6db4d11c5632c5b41bad0ac1b3b581b1
- md5sums = c7a7e64586bebde20886cc731bf2d38c
+ md5sums = 07949190c746cf5227629051ce512338
md5sums = 8f007861efc61ced5abf9ee74030afb9
+ md5sums = 25396090b1aa912bb31facb1ab8dc03a
pkgname = saluto-lightdm-theme-dwm
diff --git a/9wm.desktop b/9wm.desktop
new file mode 100644
index 000000000000..369fc41f718d
--- /dev/null
+++ b/9wm.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=9wm
+Comment=Window Manager based on rio
+Exec=9wm
+Type=XSession
+X-LightDM-DesktopName=9wm
+DesktopNames=9wm
+Keywords=wm;windowmanager;window;manager;rio;
diff --git a/9wm.png b/9wm.png
new file mode 100644
index 000000000000..6ba709ae8914
--- /dev/null
+++ b/9wm.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index f633e88ce2a1..373c258404bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=saluto-lightdm-theme-dwm
_pkgname=Saluto
pkgver=3.0.0
pkgrel=1
-pkgdesc="Saluto: Litarvan LightDM Theme Fork, with added support for DWM"
+pkgdesc="Saluto: Litarvan LightDM Theme Fork, with added support for DWM and 9wm"
arch=('any')
url="https://github.com/Demonstrandum/Saluto"
license=('MIT')
@@ -14,10 +14,11 @@ conflicts=("saluto-lightdm-theme" "saluto-lightdm-theme-git")
provides=("saluto-lightdm-theme")
md5sums=(
'SKIP' # git repo
+ '14d9664d047ee55374b9cdf3aaba4e64' # dwm-9wm.diff
'4b077e28d1dcde5ead555d6f433da37b' # dwm.desktop
- '6db4d11c5632c5b41bad0ac1b3b581b1' # dwm-lightdm.diff
- 'c7a7e64586bebde20886cc731bf2d38c' # dwm-vue.diff
+ '07949190c746cf5227629051ce512338' # 9wm.desktop
'8f007861efc61ced5abf9ee74030afb9' # dwm.png
+ '25396090b1aa912bb31facb1ab8dc03a' # 9wm.png
)
pkgver() {
@@ -28,37 +29,49 @@ pkgver() {
source=(
"git+https://github.com/Demonstrandum/Saluto"
+ "dwm-9wm.diff"
"dwm.desktop"
- "dwm-lightdm.diff"
- "dwm-vue.diff"
+ "9wm.desktop"
"dwm.png"
+ "9wm.png"
)
prepare() {
- # Add dwm logo
- mv dwm.png "$srcdir/Saluto/src/assets/default_images/desktops/dwm.png"
- # Add patches that include dwm logo
- mv dwm-vue.diff "$srcdir/Saluto/src/components/"
- mv dwm-lightdm.diff "$srcdir/Saluto/src/"
+ # Add dwm & 9wm logos
+ mv dwm.png 9wm.png "$srcdir/Saluto/src/assets/default_images/desktops/"
- # Check if dwm desktop file exists
- [[ -f "/usr/share/xsessions/dwm.desktop" ]] && printf "dwm desktop file already exists, skipping...\n" || printf "dwm desktop file DOES NOT exist, creating...\n"; sudo mv dwm.desktop /usr/share/xsessions/dwm.desktop
+ # Add patch that includes custom logos
+ mv dwm-9wm.diff "$srcdir/Saluto/src/" # /components
- # Patch "lightdm.js"
+ # Use doas instead of sudo, if installed
+ [ $(which doas) ] && rootcmd=doas || rootcmd=sudo
+
+ # Check if desktop files exist
+ [[ -f "/usr/share/xsessions/dwm.desktop" ]] && printf "dwm desktop file already exists, skipping...\n" || printf "dwm desktop file DOES NOT exist, creating...\n"; $rootcmd mv dwm.desktop /usr/share/xsessions/dwm.desktop
+
+ [[ -f "/usr/share/xsessions/9wm.desktop" ]] && printf "9wm desktop file already exists, skipping...\n" || printf "9wm desktop file DOES NOT exist, creating...\n"; $rootcmd mv 9wm.desktop /usr/share/xsessions/9wm.desktop
+
+ # Patch files
cd "$srcdir/Saluto/src"
- patch < dwm-lightdm.diff
+ patch -i dwm-9wm.diff
- # Patch "SelectItem.vue"
- cd "$srcdir/Saluto/src/components"
- patch < dwm-vue.diff
+ # Make sure "node-sass" version 4 is installed
+ npm install "node-sass@^4.0.0"
}
package() {
# Install saluto
cd "$srcdir/Saluto" && sh install.sh
+ # Use doas instead of sudo, if installed
+ [ $(which doas) ] && rootcmd=doas || rootcmd=sudo
+
# Choose lightdm-webkit2 as main LightDM greeter
- sudo sed -i "s/^greeter-session = [a-zA-Z]*\-[a-zA-Z0-9]*\-greeter/greeter-session = lightdm-webkit2-greeter/g" /etc/lightdm/lightdm.conf
+ $rootcmd sed -i "s/^greeter-session = [a-zA-Z]*\-[a-zA-Z0-9]*\-greeter/greeter-session = lightdm-webkit2-greeter/g" /etc/lightdm/lightdm.conf
+
+ # Enable XSessions directories
+ $rootcmd sed -i "s/^#sessions-directory=.*/sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions/g" /etc/lightdm/lightdm.conf
+
# Choose "saluto" as webkit2 greeter
- sudo sed -i "s/webkit_theme[ \t]*= [a-zA-Z0-9]*/webkit_theme = saluto/" /etc/lightdm/lightdm-webkit2-greeter.conf
+ $rootcmd sed -i "s/webkit_theme[ \t]*= [a-zA-Z0-9]*/webkit_theme = saluto/" /etc/lightdm/lightdm-webkit2-greeter.conf
}
diff --git a/dwm-9wm.diff b/dwm-9wm.diff
new file mode 100644
index 000000000000..71ffd3b04197
--- /dev/null
+++ b/dwm-9wm.diff
@@ -0,0 +1,61 @@
+# Patch made by Salonia Matteo <saloniamatteo@protonmail.com>
+# Made for saluto-lightdm-theme-dwm
+# Apply to Saluto/src/lightdm.js and to Saluto/src/components/SelectItem.vue
+--- lightdm.js
++++ lightdm.js
+@@ -19,7 +19,7 @@ if (window.lightdm_debug) {
+
+ window.lightdm = {
+ is_authenticated: false,
+- hostname: 'malorum',
++ hostname: 'arch',
+ authentication_user: undefined,
+ default_session: 'plasma-shell',
+ can_suspend: true,
+@@ -47,22 +47,23 @@ if (window.lightdm_debug) {
+ {
+ name: 'xmonad',
+ key: 'xmonad'
+- }
++ },
++ {
++ name: 'dwm',
++ key: 'dwm'
++ },
++ {
++ name: '9wm',
++ key: '9wm'
++ }
+ ],
+ users: [{
+- display_name: 'Marcus Tullius Cicero',
+- username: 'cicero',
+- image: 'cicero'
+- }, {
+- display_name: 'John Doe',
+- username: 'johnd'
++ display_name: 'User',
++ username: 'username'
+ }],
+ languages: [{
+ name: 'American English',
+ code: 'en_US.utf8'
+- }, {
+- name: 'Français',
+- code: 'fr_FR.utf8'
+ }],
+ language: 'American English',
+ start_authentication: (username) => {
+--- components/SelectItem.vue
++++ components/SelectItem.vue
+@@ -72,6 +72,10 @@ export default {
+ icon = "liri";
+ } else if (key.indexOf("i3") > -1) {
+ icon = "i3";
++ } else if (key.indexOf("dwm") > -1) {
++ icon = "dwm";
++ } else if (key.indexOf("9wm") > -1) {
++ icon = "9wm";
+ } else if (key.indexOf("xmonad") > -1) {
+ icon = "xmonad";
+ } else if (key.indexOf("budgie") > -1 || key.indexOf("solus") > -1) {
diff --git a/dwm-lightdm.diff b/dwm-lightdm.diff
deleted file mode 100644
index 0485c7e5149d..000000000000
--- a/dwm-lightdm.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-# Patch made by Salonia Matteo <saloniamatteo@protonmail.com>
-# Made for saluto-lightdm-theme-dwm
-# Apply to saluto/src/lightdm.js
---- lightdm.js 2020-11-22 09:32:31.708516415 +0100
-+++ lightdm.js 2020-11-22 09:32:07.781741362 +0100
-@@ -47,7 +47,11 @@
- {
- name: 'xmonad',
- key: 'xmonad'
-- }
-+ },
-+ {
-+ name: 'dwm',
-+ key: 'dwm'
-+ }
- ],
- users: [{
- display_name: 'Marcus Tullius Cicero',
diff --git a/dwm-vue.diff b/dwm-vue.diff
deleted file mode 100644
index f896d6bc8065..000000000000
--- a/dwm-vue.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-# Patch made by Salonia Matteo <saloniamatteo@protonmail.com>
-# Made for saluto-lightdm-theme-dwm
-# Apply to saluto/src/components/SelectItem.vue
---- SelectItem.vue 2020-11-22 09:29:06.970922306 +0100
-+++ SelectItem.vue 2020-11-22 09:30:30.937969341 +0100
-@@ -72,6 +72,8 @@
- icon = "liri";
- } else if (key.indexOf("i3") > -1) {
- icon = "i3";
-+ } else if (key.indexOf("dwm") > -1) {
-+ icon = "dwm";
- } else if (key.indexOf("xmonad") > -1) {
- icon = "xmonad";
- } else if (key.indexOf("budgie") > -1 || key.indexOf("solus") > -1) {