summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaloniamatteo2021-03-07 10:02:14 +0100
committersaloniamatteo2021-03-07 10:02:14 +0100
commitb7c2c49636814cc3eb07dfa4a78218eea35d7579 (patch)
tree01d0ea832b40566bf11c94064a016f6b5f883107
parenta7e86054d31399994e3c894d7066d07c1b1f081c (diff)
downloadaur-b7c2c49636814cc3eb07dfa4a78218eea35d7579.tar.gz
Add missing node dependencies
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba292d82943f..b7057c683209 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,19 +76,13 @@ prepare() {
cd "$srcdir/Saluto/src"
patch -p0 -i dwm-9wm-rio.diff
- # Make sure "node-sass" version 4 is installed
- npm install "node-sass@^4.0.0"
+ # Make sure node dependencies are installed
+ npm install "node-sass@^4.0.0" "simple-keyboard"
}
package() {
-
- cd "$srcdir/Saluto"
-
- # Fix author's mistake
- sed -i "s/^cd \.\/dist/cd \.\.\/dist/" install.sh
-
# Install Saluto
- sh install.sh
+ cd "$srcdir/Saluto" && sh install.sh
# Use doas instead of sudo, if installed
[ $(which doas) ] && rootcmd=doas || rootcmd=sudo