summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-08-12 10:36:34 +0200
committeraksr2016-08-12 10:36:34 +0200
commitaaa4045b6064c19285be34eebf6f4341cc9efd84 (patch)
treee5500790a715bbd77240a6adc500a29e4a8e3806
downloadaur-aaa4045b6064c19285be34eebf6f4341cc9efd84.tar.gz
Start.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c463504477d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Aug 12 08:36:34 UTC 2016
+pkgbase = sam-git
+ pkgdesc = An updated version of the sam text editor.
+ pkgver = r110.66c9497
+ pkgrel = 1
+ url = https://github.com/deadpixi/sam
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ source = sam-git::git+https://github.com/deadpixi/sam.git
+ md5sums = SKIP
+
+pkgname = sam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5312276a068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=sam-git
+pkgver=r110.66c9497
+pkgrel=1
+epoch=
+pkgdesc="An updated version of the sam text editor."
+arch=('i686' 'x86_64')
+url="https://github.com/deadpixi/sam"
+license=('custom')
+categories=()
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/deadpixi/sam.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/usr" install
+ install -Dm644 README.rst $pkgdir/usr/share/doc/${pkgname%-*}/README.rst
+ install -Dm644 doc/sam.ps $pkgdir/usr/share/doc/${pkgname%-*}/sam.ps
+ install -Dm644 doc/se.ps $pkgdir/usr/share/doc/${pkgname%-*}/se.ps
+ install -Dm644 doc/keyboard $pkgdir/usr/share/doc/${pkgname%-*}/sample/keyboard
+ install -Dm644 doc/keyboard.5 $pkgdir/usr/share/man/man5/keyboard.5
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+