summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:50:19 +0200
committerStefan Husmann2015-06-09 00:50:19 +0200
commit4bf849fdac7ec2911bcb9196df84c7aa23dfd64d (patch)
treeb54e836ee04f299617ccb818a990147b6c1ac47a
downloadaur-4bf849fdac7ec2911bcb9196df84c7aa23dfd64d.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--makedep.patch36
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38f685404b0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sam2p
+ pkgdesc = A bitmap-to-eps-or-pdf-converter that produces very small files
+ pkgver = 0.49.2
+ pkgrel = 2
+ url = http://www.inf.bme.hu/~pts
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = makedepend
+ depends = gcc-libs
+ optdepends = ghostscript: PS, EPS, PDF support
+ optdepends = libjpeg: JPEG support
+ optdepends = tif22pnm: for tiff and png support
+ source = http://sam2p.googlecode.com/files/sam2p-0.49.2.tar.gz
+ source = makedep.patch
+ md5sums = fd46bcd21576cf9441fc80639a6033b0
+ md5sums = 3c7754d87b6e1b43b6a37db3944c2c91
+
+pkgname = sam2p
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6e62f4ecea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Jonathan Liu <net147@hotmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: menta
+
+pkgname=sam2p
+pkgver=0.49.2
+pkgrel=2
+pkgdesc="A bitmap-to-eps-or-pdf-converter that produces very small files"
+arch=('i686' 'x86_64')
+url="http://www.inf.bme.hu/~pts"
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('makedepend')
+optdepends=('ghostscript: PS, EPS, PDF support'
+'libjpeg: JPEG support'
+'tif22pnm: for tiff and png support')
+# 'netpbm: PNG support'
+source=("http://sam2p.googlecode.com/files/$pkgname-$pkgver.tar.gz" makedep.patch)
+md5sums=('fd46bcd21576cf9441fc80639a6033b0'
+ '3c7754d87b6e1b43b6a37db3944c2c91')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < $srcdir/makedep.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix="$pkgdir"/usr --enable-lzw --enable-gif
+ make all
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make install
+ install -D -m644 README "$pkgdir"/usr/share/sam2p/docs/README
+}
diff --git a/makedep.patch b/makedep.patch
new file mode 100644
index 000000000000..35ea36735f19
--- /dev/null
+++ b/makedep.patch
@@ -0,0 +1,36 @@
+diff -Naur sam2p-0.49.2.orig/aclocal.m4 sam2p-0.49.2.new/aclocal.m4
+--- sam2p-0.49.2.orig/aclocal.m4 2013-09-03 16:32:54.000000000 +0200
++++ sam2p-0.49.2.new/aclocal.m4 2015-02-23 20:27:49.944550310 +0100
+@@ -777,7 +777,7 @@
+ #ifdef __cplusplus
+ extern "C" void exit(int);
+ #endif
+-#define _BSD_SOURCE 1 /* vsnprintf */
++#define _DEFAULT_SOURCE 1 /* vsnprintf */
+ #define _POSIX_SOURCE 1
+ #define _POSIX_C_SOURCE 2
+ #include <stdio.h>
+diff -Naur sam2p-0.49.2.orig/configure sam2p-0.49.2.new/configure
+--- sam2p-0.49.2.orig/configure 2013-09-03 16:32:54.000000000 +0200
++++ sam2p-0.49.2.new/configure 2015-02-23 20:24:48.251635254 +0100
+@@ -5218,7 +5218,7 @@
+ #ifdef __cplusplus
+ extern "C" void exit(int);
+ #endif
+-#define _BSD_SOURCE 1 /* vsnprintf */
++#define _DEFAULT_SOURCE 1 /* vsnprintf */
+ #define _POSIX_SOURCE 1
+ #define _POSIX_C_SOURCE 2
+ #include <stdio.h>
+diff -Naur sam2p-0.49.2.orig/gensio.cpp sam2p-0.49.2.new/gensio.cpp
+--- sam2p-0.49.2.orig/gensio.cpp 2013-09-03 16:32:54.000000000 +0200
++++ sam2p-0.49.2.new/gensio.cpp 2015-02-23 20:28:40.624393545 +0100
+@@ -15,7 +15,7 @@
+ extern "C" int _v_s_n_printf ( char *str, size_t n, const char *format, va_list ap );
+ #else
+ #undef __STRICT_ANSI__ /* for __MINGW32__ */
+-#define _BSD_SOURCE 1 /* vsnprintf(); may be emulated with fixup_vsnprintf() */
++#define _DEFAULT_SOURCE 1 /* vsnprintf(); may be emulated with fixup_vsnprintf() */
+ #ifndef __APPLE__ /* SUXX: Max OS X has #ifndef _POSIX_SOURCE around lstat() :-( */
+ #define _POSIX_SOURCE 1 /* also popen() */
+ #endif