summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvedui2020-05-17 17:14:57 +0200
committerArvedui2020-05-17 17:14:57 +0200
commit3a7a2ce17a7d51d315fd9792cca505fda43bd760 (patch)
tree6fc1210c2cea2b62fa5bef8321b5d884c5993d17
downloadaur-3a7a2ce17a7d51d315fd9792cca505fda43bd760.tar.gz
Add sameboy PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25a382d8d6b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sameboy
+ pkgdesc = An accuracy-focused Game Boy/Game Boy Color emulator
+ pkgver = 0.12.3
+ pkgrel = 1
+ url = https://github.com/LIJI32/SameBoy
+ arch = x86_64
+ license = MIT
+ makedepends = rgbds
+ makedepends = make
+ makedepends = git
+ depends = sdl2
+ source = sameboy-0.12.3.tar.gz::https://github.com/LIJI32/SameBoy/archive/v0.12.3.tar.gz
+ md5sums = b3fc66405a40b508fd8e13ec0db9b860
+
+pkgname = sameboy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20fba5da5b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Arvedui <arvedui@posteo.de>
+# Contributor: Jakub Kądziołka <kuba@kadziolka.net>
+
+pkgname=sameboy
+pkgdesc="An accuracy-focused Game Boy/Game Boy Color emulator"
+pkgver=0.12.3
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/LIJI32/SameBoy"
+license=(MIT)
+depends=(sdl2)
+# Upstream suggests using clang, but gcc is supported on Linux: https://github.com/LIJI32/SameBoy/issues/164#issuecomment-486464194
+makedepends=(rgbds make git)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LIJI32/SameBoy/archive/v${pkgver}.tar.gz")
+md5sums=('b3fc66405a40b508fd8e13ec0db9b860')
+
+build(){
+ cd "${srcdir}/SameBoy-${pkgver}"
+ make sdl CONF=release DATA_DIR=/usr/share/games/sameboy/ CC=gcc
+}
+
+package(){
+ cd "${srcdir}/SameBoy-${pkgver}"
+ install -Dm755 build/bin/SDL/sameboy "$pkgdir/usr/bin/sameboy"
+ find build/bin/SDL -type f -not -executable | while read f; do
+ install -Dm644 "$f" "$pkgdir/usr/share/games/sameboy/${f#build/bin/SDL/}"
+ done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/sameboy-git/LICENSE"
+}