summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNieDzejkob2018-11-10 16:40:22 +0100
committerNieDzejkob2018-11-10 16:40:22 +0100
commit3dd0c919d7c62a42491614dce57c27dea7524ade (patch)
tree19358baec39b175892bb538aaaaf606ef7cd48ef
downloadaur-3dd0c919d7c62a42491614dce57c27dea7524ade.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee1b801829eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sameboy-git
+ pkgdesc = An accuracy-focused Game Boy/Game Boy Color emulator
+ pkgver = 819.969fb5a
+ pkgrel = 1
+ url = https://github.com/LIJI32/SameBoy
+ arch = x86_64
+ license = MIT
+ makedepends = clang
+ makedepends = rgbds
+ makedepends = make
+ makedepends = git
+ depends = sdl2
+ source = git+ssh://git@github.com/LIJI32/SameBoy.git
+ sha1sums = SKIP
+
+pkgname = sameboy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f21d2b886743
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jakub Kądziołka <kuba@kadziolka.net>
+
+pkgname=sameboy-git
+pkgdesc="An accuracy-focused Game Boy/Game Boy Color emulator"
+pkgver=819.969fb5a
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/LIJI32/SameBoy"
+license=(MIT)
+depends=(sdl2)
+# Upstream requires clang, so using gcc might break
+makedepends=(clang rgbds make git)
+source=(git+ssh://git@github.com/LIJI32/SameBoy.git)
+sha1sums=(SKIP)
+
+pkgver(){
+ cd SameBoy
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build(){
+ cd SameBoy
+ make sdl CONF=release DATA_DIR=/usr/share/games/sameboy/
+}
+
+package(){
+ cd SameBoy
+ install -Dm755 build/bin/SDL/sameboy "$pkgdir/usr/bin/sameboy"
+ find build/bin/SDL -type f -not -executable | while read f; do
+ install -Dm644 "$f" "$pkgdir/usr/share/games/sameboy/${f#build/bin/SDL/}"
+ done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/sameboy-git/LICENSE"
+}