summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Müller2018-12-17 12:46:53 +0100
committerThorsten Müller2018-12-17 12:46:53 +0100
commit18c177ca8a82dccada5c535765b16ec028d24f45 (patch)
tree27911bd91358c48d23aacdc258d9c0f16cffa70f
downloadaur-18c177ca8a82dccada5c535765b16ec028d24f45.tar.gz
samhain server version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--samhain.install6
-rw-r--r--yule.service10
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0eb56b06e42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = samhain-server
+ pkgdesc = file integrity / intrusion detection system
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = http://www.la-samhna.de/
+ install = samhain.install
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ source = http://www.la-samhna.de/samhain/samhain-current.tar.gz
+ source = yule.service
+ validpgpkeys = EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C
+ sha256sums = d4dcedc6bc579c935de7972d23675e94654391c3a1bd19c06ec38e57f7faf1f2
+ sha256sums = f8c579fd60b1004272351f257374615d99adab43249b746f557abf0f91cd4c90
+
+pkgname = samhain-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd6a2224b550
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Thorsten Mueller <info@thorko.de>
+# Contributor:
+
+pkgname=samhain-server
+pkgver=4.3.1
+pkgrel=1
+pkgdesc="file integrity / intrusion detection system"
+arch=(x86_64 armv7h)
+url="http://www.la-samhna.de/"
+license=('GPL')
+install=samhain.install
+source=("http://www.la-samhna.de/samhain/samhain-current.tar.gz"
+ "yule.service")
+sha256sums=('d4dcedc6bc579c935de7972d23675e94654391c3a1bd19c06ec38e57f7faf1f2'
+ 'f8c579fd60b1004272351f257374615d99adab43249b746f557abf0f91cd4c90')
+validpgpkeys=('EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C')
+
+build() {
+ echo "Note: If the GPG verification fails, import the Samhain GPG key: http://www.la-samhna.de/samhain/s_rkey.html"
+ gpg --verify samhain-${pkgver}.tar.gz.asc samhain-${pkgver}.tar.gz
+ tar -zxvf samhain-${pkgver}.tar.gz
+ cd "samhain-${pkgver}"
+ # see samhain documentation, lots of other options available. e.g. use --enable-network=server to run in server mode.
+ #./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin --enable-network=server
+ make
+}
+
+package() {
+ cd "samhain-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+ chmod 755 ${pkgdir}/usr/bin/yule
+ chmod 755 ${pkgdir}/usr/bin/yuleadmin.pl
+ chmod 755 ${pkgdir}/usr/bin/yule_setpwd
+ chmod 755 ${pkgdir}/usr/bin/yulectl
+ chmod 644 ${pkgdir}/etc/yulerc
+ install -m755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m644 "${srcdir}/yule.service" "${pkgdir}/usr/lib/systemd/system/yule.service"
+ rmdir ${pkgdir}/run
+ rm -rf ${pkgdir}/var/log
+}
diff --git a/samhain.install b/samhain.install
new file mode 100644
index 000000000000..6c08e223f66e
--- /dev/null
+++ b/samhain.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "NOTE: samhain works by comparing the present state of the filesystem agains a"
+ echo "baseline database. If this is the first time that you are using samhain you"
+ echo "will need to perform the initialization (i.e. create the baseline database)"
+ echo "type the following command: samhain -t init"
+}
diff --git a/yule.service b/yule.service
new file mode 100644
index 000000000000..90dbdb514853
--- /dev/null
+++ b/yule.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Samhain HIDS
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/yule start
+ExecStop=/usr/sbin/yule stop
+
+[Install]
+WantedBy=multi-user.target