summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-21 22:02:30 +0330
committerMohammadreza Abdollahzadeh2017-01-21 22:02:30 +0330
commit04155567fd65fa690088ae6431db8e98d38b033c (patch)
tree31408ae50e4d2bd1e07aa887522b8c386770c0d2
downloadaur-04155567fd65fa690088ae6431db8e98d38b033c.tar.gz
Initial Import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2834863b5d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 18:32:12 UTC 2017
+pkgbase = samim-fonts
+ pkgdesc = A beautiful Persian font based on Vazir font.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://rastikerdar.github.io/samim-font/
+ arch = any
+ license = OFL
+ depends = fontconfig
+ provides = ttf-samim
+ provides = samim-fonts
+ conflicts = ttf-samim
+ conflicts = samim-fonts
+ replaces = ttf-samim
+ source = samim-fonts-1.0.2.zip::https://github.com/rastikerdar/samim-font/releases/download/v1.0.2/samim-font-v1.0.2.zip
+ sha256sums = 1cdcc17cc40c422d9dce7491a5ba9701bf2a6947c42295ccc81218cbe786854e
+
+pkgname = samim-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..217007efa23c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=samim-fonts
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A beautiful Persian font based on Vazir font."
+url="https://rastikerdar.github.io/samim-font/"
+arch=(any)
+license=('OFL')
+depends=('fontconfig')
+provides=('ttf-samim' "$pkgname")
+conflicts=('ttf-samim' "$pkgname")
+replaces=('ttf-samim')
+source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/samim-font/releases/download/v$pkgver/samim-font-v$pkgver.zip")
+sha256sums=('1cdcc17cc40c422d9dce7491a5ba9701bf2a6947c42295ccc81218cbe786854e')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Samim*.{eot,ttf,woff}
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./{Farsi*,Without-Latin}/Samim*.{eot,ttf,woff}
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: