summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAilton Baúque2023-07-03 06:42:34 +0200
committerAilton Baúque2023-07-03 06:42:34 +0200
commite23f17f652673381ba903a89feaafabf4196e255 (patch)
tree28a0760576aec9bff96a4a3b9a2335e4920e63a3
downloadaur-e23f17f652673381ba903a89feaafabf4196e255.tar.gz
Initial push.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1318e459f9e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = samora-lang
+ pkgdesc = Samora Lang - A Simple Interpreted Programming Language just for Educational Purposes
+ pkgver = 1.20.4.r.
+ pkgrel = 1
+ url = https://github.com/GraHms/Samora-Lang
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = go
+ depends = go
+ provides = samora
+ source = git+https://github.com/GraHms/Samora-Lang
+ md5sums = SKIP
+
+pkgname = samora-lang
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcc09ea1c76c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Ailton Baúque <ailtonbauque@outlook.com>
+
+pkgname=samora-lang
+pkgver=1.20.4.r.
+pkgrel=1
+pkgdesc="Samora Lang - A Simple Interpreted Programming Language just for Educational Purposes"
+arch=('x86_64' 'i686')
+url="https://github.com/GraHms/Samora-Lang"
+license=('MIT')
+groups=()
+depends=('go')
+makedepends=('git' 'go')
+checkdepends=()
+optdepends=()
+provides=('samora')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+
+pkgver(){
+ cd "${_pkgname}"
+ printf "1.20.4.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/Samora-Lang"
+
+ go mod download
+}
+
+build() {
+ cd "${srcdir}/Samora-Lang"
+
+ go build -v ./...
+}
+
+check() {
+ cd "${srcdir}/Samora-Lang"
+
+ go test -v ./...
+}
+
+package() {
+ cd "${srcdir}/Samora-Lang"
+
+ install -Dm755 samora "${pkgdir}/opt/${pkgname}/samora"
+ #install -Dm755 LICENSE "${pkgdir}/usr/share/licences/${pkgname}/LICENSE"
+ install -Dm755 README.md "${pkgdir}/usr/share/docs/${pkgname}/README.md"
+}
+
+post_install() {
+ ln -s "/opt/${pkgname}/samora" "/usr/bin/samora"
+}
+
+post_remove() {
+ rm -f "/usr/bin/samora"
+}
+