summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortelans2019-10-21 13:39:08 +1300
committertelans2019-10-21 13:39:08 +1300
commit35b80f8be5dc5ca5e7b99322d4e355a8bd3593ee (patch)
tree7a1b041349d3eb3ec87d74297aff2aa5533944e2
downloadaur-35b80f8be5dc5ca5e7b99322d4e355a8bd3593ee.tar.gz
initial commit, from sam-rewritten-git
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD39
-rwxr-xr-xsamrewritten.desktop8
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b6bad2b5f7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = samrewritten-git
+ pkgdesc = A Steam Achievement Manager For Linux.
+ pkgver = r39.50f2d7b
+ pkgrel = 1
+ url = https://github.com/PaulCombal/SamRewritten
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = steam
+ depends = yajl
+ depends = gtk3
+ depends = glibc
+ conflicts = sam-rewritten-git
+ source = git+https://github.com/PaulCombal/SamRewritten.git
+ source = samrewritten.desktop
+ md5sums = SKIP
+ md5sums = 84c9216c71f336e1dabd462815a157ef
+
+pkgname = samrewritten-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..590db4ab1f4d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore all
+*
+
+# Except
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!samrewritten.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82d3fbf08e51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: telans <telans@protonmail.com>
+# Co-Maintainer: Simon Tas <simon.tas.st@gmail.com>
+
+pkgname="samrewritten-git"
+_pkgname="SamRewritten"
+pkgver=r39.50f2d7b
+pkgrel=1
+pkgdesc="A Steam Achievement Manager For Linux."
+arch=("any")
+url="https://github.com/PaulCombal/SamRewritten"
+license=("GPL3")
+depends=("steam" "yajl" "gtk3" "glibc")
+makedepends=("git")
+conflicts=("sam-rewritten-git")
+source=("git+https://github.com/PaulCombal/SamRewritten.git"
+ "samrewritten.desktop")
+md5sums=("SKIP"
+ "84c9216c71f336e1dabd462815a157ef")
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_pkgname}
+ ./make.sh
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/lib/"
+ # Only copy required files. (Except for Glade files, as more may be added in the future.)
+ cp --parents ${_pkgname}/{LICENSE,README.MD,bin/{launch.sh,libsteam_api.so,samrewritten},glade/*.glade} "${pkgdir}/usr/lib/"
+ # Executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/usr/lib/${_pkgname}/bin/launch.sh" "${pkgdir}/usr/bin/samrewritten"
+ # Desktop Entry
+ install -Dm644 "samrewritten.desktop" "${pkgdir}/usr/share/applications/samrewritten.desktop"
+}
diff --git a/samrewritten.desktop b/samrewritten.desktop
new file mode 100755
index 000000000000..956b5507a5af
--- /dev/null
+++ b/samrewritten.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=SamRewritten
+Exec=/usr/bin/samrewritten
+Terminal=false
+Type=Application
+Icon=face-wink
+Comment=Steam Achievement Manager
+Categories=Game;