summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pierce2020-04-14 03:51:14 -0700
committerWilliam Pierce2020-04-14 03:51:14 -0700
commita51772d1ad5c17ff8549316d36bd539c4732a698 (patch)
treee7e4e4c5cc0b0e9e11ea435936aa9de4cfb64423
parente81af6b2a3e10edaceb0fe316a3b7d7059f92d76 (diff)
downloadaur-a51772d1ad5c17ff8549316d36bd539c4732a698.tar.gz
Update to upstream pkgbuild
Doing so picks up gtkmm3 and curl dependencies to allow the current AUR package to build. Upstream also includes a .desktop, so no need to maintain it here. sam-rewritten-git is long gone by now and should no longer be a problem.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
-rwxr-xr-xsamrewritten.desktop9
3 files changed, 27 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26eac94b43a8..30662e11da40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = samrewritten-git
pkgdesc = A Steam Achievement Manager For Linux.
- pkgver = r119.7ff28cf
- pkgrel = 2
+ pkgver = r135.cbc9583
+ pkgrel = 1
url = https://github.com/PaulCombal/SamRewritten
arch = any
license = GPL3
makedepends = git
+ makedepends = make
+ makedepends = gcc>=9.0
depends = steam
depends = yajl
- depends = gtk3
+ depends = gtkmm3
depends = glibc
- conflicts = sam-rewritten-git
+ depends = curl
+ optdepends = zenity: error messages with style
+ optdepends = valgrind: for automated dev script
+ optdepends = massif-visualizer: for automated dev script
source = git+https://github.com/PaulCombal/SamRewritten.git
- source = samrewritten.desktop
sha256sums = SKIP
- sha256sums = 0a2cb9f113839dab134738500d14987ba825449701f1782ef4d269c325f2f9e1
pkgname = samrewritten-git
diff --git a/PKGBUILD b/PKGBUILD
index ee120314e938..9a3bf7115ef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
pkgname="samrewritten-git"
_pkgname="SamRewritten"
-pkgver=r119.7ff28cf
-pkgrel=2
+pkgver=r135.cbc9583
+pkgrel=1
pkgdesc="A Steam Achievement Manager For Linux."
arch=("any")
url="https://github.com/PaulCombal/SamRewritten"
license=("GPL3")
-depends=("steam" "yajl" "gtk3" "glibc")
-makedepends=("git")
-conflicts=("sam-rewritten-git")
-source=("git+https://github.com/PaulCombal/SamRewritten.git"
- "samrewritten.desktop")
-sha256sums=("SKIP"
- "0a2cb9f113839dab134738500d14987ba825449701f1782ef4d269c325f2f9e1")
+depends=("steam" "yajl" "gtkmm3" "glibc" "curl")
+optdepends=("zenity: error messages with style"
+ "valgrind: for automated dev script"
+ "massif-visualizer: for automated dev script")
+makedepends=("git" "make" "gcc>=9.0")
+source=("git+https://github.com/PaulCombal/SamRewritten.git")
+sha256sums=("SKIP")
pkgver() {
cd ${_pkgname}
@@ -24,19 +24,18 @@ pkgver() {
build() {
cd ${_pkgname}
- make clean
make
}
-package() {
+package() {
install -dm755 "${pkgdir}/usr/lib/"
- # Copy required files.
- cp -r --parents ${_pkgname}/{LICENSE,README.MD,bin/{launch.sh,libsteam_api.so,samrewritten},glade,assets/icon_256.png} "${pkgdir}/usr/lib/"
- install -Dm644 "${_pkgname}/assets/icon_256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/samrewritten.png"
- install -Dm644 "${_pkgname}/assets/icon_64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/samrewritten.png"
+ # Only copy required files. (Except for Glade files, as more may be added in the future.)
+ cp -r --parents ${_pkgname}/{LICENSE,README.MD,bin/{launch.sh,libsteam_api.so,samrewritten},glade/*.glade,assets/icon_256.png} ${pkgdir}/usr/lib/
+ install -Dm644 ${_pkgname}/assets/icon_256.png ${pkgdir}/usr/share/icons/hicolor/256x256/apps/samrewritten.png
+ install -Dm644 ${_pkgname}/assets/icon_64.png ${pkgdir}/usr/share/icons/hicolor/64x64/apps/samrewritten.png
# Executable
- install -dm755 "${pkgdir}/usr/bin"
- ln -s "/usr/lib/${_pkgname}/bin/launch.sh" "${pkgdir}/usr/bin/samrewritten"
+ install -dm755 ${pkgdir}/usr/bin
+ ln -s /usr/lib/${_pkgname}/bin/launch.sh ${pkgdir}/usr/bin/samrewritten
# Desktop Entry
- install -Dm644 "samrewritten.desktop" "${pkgdir}/usr/share/applications/samrewritten.desktop"
-}
+ install -Dm644 ${_pkgname}/package/samrewritten.desktop ${pkgdir}/usr/share/applications/samrewritten.desktop
+} \ No newline at end of file
diff --git a/samrewritten.desktop b/samrewritten.desktop
deleted file mode 100755
index e3e1d1a3ce70..000000000000
--- a/samrewritten.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=SamRewritten
-Exec=/usr/bin/samrewritten
-Terminal=false
-Type=Application
-Icon=samrewritten
-Comment=Steam Achievement Manager
-Categories=Game;
-StartupWMClass=samrewritten;