summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Oliver Oelerich2015-06-09 08:49:44 +0200
committerJan Oliver Oelerich2015-06-09 08:49:44 +0200
commit1b25031c4d40e3a5097ce01bf7c561a0d6b4b522 (patch)
treeb3eb8d8838aee838d3273b6c4dbe556ec241ff0b
downloadaur-1b25031c4d40e3a5097ce01bf7c561a0d6b4b522.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30967e76104e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = samsung-ml-1915
+ pkgdesc = Samsung ML-1915 CUPS driver
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.samsung.com
+ arch = i686
+ arch = x86_64
+ license = custom:samsung
+ depends = cups
+ depends = ghostscript
+ source = http://downloadcenter.samsung.com/content/DR/200911/20091118142414703/UnifiedLinuxDriver_1.02.tar.gz
+ md5sums = 49e44d27a7a63ddb8ba1a5d4f650b35e
+
+pkgname = samsung-ml-1915
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdab10920cd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jan Oliver Oelerich <janoliver@oelerich.org>
+
+pkgname=samsung-ml-1915
+pkgver=1
+pkgrel=1
+pkgdesc="Samsung ML-1915 CUPS driver"
+arch=('i686' 'x86_64')
+depends=('cups' 'ghostscript')
+license='custom:samsung'
+url="http://www.samsung.com"
+source=("http://downloadcenter.samsung.com/content/DR/200911/20091118142414703/UnifiedLinuxDriver_1.02.tar.gz")
+md5sums=('49e44d27a7a63ddb8ba1a5d4f650b35e')
+
+build() {
+ cd $startdir/src/ || return 1
+ # fix wrong modes in archive
+ chmod u=rwX,g=rX cdroot -R
+ chown root:root cdroot -R
+ install -m 644 -D "$startdir/src/cdroot/Linux/noarch/at_opt/share/ppd/ML-191xspl2.ppd" \
+ "$startdir/pkg/usr/share/cups/model/ML-191xspl2.ppd"
+ if [ "$CARCH" = "x86_64" ]; then
+ install -m 755 -D "$startdir/src/cdroot/Linux/x86_64/at_root/usr/lib64/cups/filter/rastertosamsungspl" \
+ "$startdir/pkg/usr/lib/cups/filter/rastertosamsungspl"
+ else
+ install -m 755 -D "$startdir/src/cdroot/Linux/i386/at_root/usr/lib/cups/filter/rastertosamsungspl" \
+ "$startdir/pkg/usr/lib/cups/filter/rastertosamsungspl"
+ fi
+} \ No newline at end of file