summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-01 16:08:05 +0800
committerChocobo12020-09-01 16:13:55 +0800
commit767e80f791352742a6ef361b3f5ca903fa06ebf2 (patch)
treef96bbfb79742d6b468765582e75dfcd78ff9548f
downloadaur-767e80f791352742a6ef361b3f5ca903fa06ebf2.tar.gz
newpkg: samtools-git 1.10.r98.gfaab8b0-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fbf1722364a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = samtools-git
+ pkgdesc = Tools for manipulating next-generation sequencing data
+ pkgver = 1.10.r98.gfaab8b0
+ pkgrel = 1
+ url = https://www.htslib.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ depends = htslib
+ depends = ncurses
+ depends = zlib
+ provides = samtools
+ conflicts = samtools
+ source = git+https://github.com/samtools/samtools.git
+ sha256sums = SKIP
+
+pkgname = samtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa4ffa9bf7e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=samtools-git
+pkgver=1.10.r98.gfaab8b0
+pkgrel=1
+pkgdesc="Tools for manipulating next-generation sequencing data"
+arch=('i686' 'x86_64')
+url="https://www.htslib.org/"
+license=('MIT')
+depends=('glibc' 'htslib' 'ncurses' 'zlib')
+makedepends=('git')
+provides=('samtools')
+conflicts=('samtools')
+source=("git+https://github.com/samtools/samtools.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "samtools"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "samtools"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr" \
+ --with-htslib=system
+ make
+}
+
+check() {
+ cd "samtools"
+
+ #make check
+}
+
+package() {
+ cd "samtools"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "misc"/*.lua -t "$pkgdir/usr/bin"
+
+ install -Dm644 *.h -t "$pkgdir/usr/include/bam"
+
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/samtools"
+}