summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2018-01-09 13:46:59 -0500
committerDrew DeVault2018-01-09 13:46:59 -0500
commitb79fbcc7c667b01fd99cf02e750271b125b33308 (patch)
treea77e3acfc649fffcdd2c5b5514dcee33d92ffdd1
downloadaur-b79fbcc7c667b01fd99cf02e750271b125b33308.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b69efab25cfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = samurai
+ pkgdesc = ninja-compatible build tool written in C
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/michaelforney/samurai
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = samurai-0.2.tar.gz::https://github.com/michaelforney/samurai/archive/0.2.tar.gz
+ md5sums = c74fc84afcef3ac527f369ad83f74728
+
+pkgname = samurai
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..52003c53dd0a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54831ca89e6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer : Drew DeVault <sir@cmpwn.com>
+
+pkgname=samurai
+pkgver=0.2
+pkgrel=1
+pkgdesc='ninja-compatible build tool written in C'
+arch=('i686' 'x86_64')
+url='https://github.com/michaelforney/samurai'
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/michaelforney/samurai/archive/0.2.tar.gz")
+md5sums=('c74fc84afcef3ac527f369ad83f74728')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make samu
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}