summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-05-15 12:06:28 -0700
committerChristian Bundy2018-05-15 12:06:28 -0700
commit04c3bbf4d98436ff5d1326f127fcc66840e7e60b (patch)
tree11b2e65217838b23dda3e178268836224adc7bbc
downloadaur-04c3bbf4d98436ff5d1326f127fcc66840e7e60b.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c42f717b2448
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = samus-scripts
+ pkgdesc = A collection of scripts for the Chromebook Pixel (2015), codename Samus.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/christianbundy/samus-scripts
+ arch = x86_64
+ license = GPL2
+ depends = bash
+ optdepends = mxt-app
+ source = https://gitlab.com/christianbundy/samus-scripts/-/archive/v1.0.0/samus-scripts-v1.0.0.tar.gz
+ md5sums = 96d50a3a9d92a4dc6e198cc3690ebab5
+
+pkgname = samus-scripts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..828692935b96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Christian Bundy <christianbundy@fraction.io>
+# Contributor: Raphael Simon <simon.raphael@gmail.com>
+
+pkgname=samus-scripts
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A collection of scripts for the Chromebook Pixel (2015), codename Samus."
+arch=('any')
+url="https://gitlab.com/christianbundy/samus-scripts"
+license=('GPL2')
+depends=('bash')
+optdepends=('mxt-app')
+source=("https://gitlab.com/christianbundy/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('3464d61a605d52230a72460f8f682374')
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ cd "$pkgname-v$pkgver"
+ install -Dm755 scripts/**/*.sh "${pkgdir}/usr/bin/"
+}