summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsandangel2017-02-15 22:18:47 +0900
committersandangel2017-02-15 22:18:47 +0900
commitac3132cc78461528b00cea5ab6c1c88b00d9ed2d (patch)
treeea24e0ca0aeaa454a56a698e5d586aee31bab167
downloadaur-ac3132cc78461528b00cea5ab6c1c88b00d9ed2d.tar.gz
sand-lxqt-theme
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38c05a1814ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sand-lxqt-theme
+ pkgdesc = Dark theme for the LXQt Desktop, color scheme for qterminal, lxqt-panel, mixed between breeze and ambiance
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/sandangel/sand-lxqt-theme
+ arch = any
+ license = custom:sand
+ makedepends = git
+ optdepends = breeze-icons: Breeze icon themes
+ source = https://github.com/sandangel/sand-lxqt-theme/raw/master/archive/sand-1.0.tar.xz
+ md5sums = 544c45ad7f2f9eedd8ef248a29d10168
+
+pkgname = sand-lxqt-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca4b2f13c9c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: sand <https://github.com/sandangel/sand-lxqt-theme/tree/master>
+_pkgname=sand
+pkgname=sand-lxqt-theme
+pkgver=1.0
+pkgrel=1
+pkgdesc="Dark theme for the LXQt Desktop, color scheme for qterminal, lxqt-panel, mixed between breeze and ambiance"
+arch=('any')
+url="https://github.com/sandangel/sand-lxqt-theme"
+license=('custom:sand')
+
+depends=('')
+makedepends=('git')
+optdepends=('breeze-icons: Breeze icon themes')
+
+source=("https://github.com/sandangel/sand-lxqt-theme/raw/master/archive/${_pkgname}-${pkgver}.tar.xz")
+
+md5sums=('544c45ad7f2f9eedd8ef248a29d10168')
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ install -dm 755 "${pkgdir}"/usr/share/lxqt/themes/${_pkgname}
+ install -dm 755 "${pkgdir}"/usr/share/color-schemes
+ install -dm 755 "${pkgdir}"/usr/share/qtermwidget5/color-schemes
+ cp -a --no-preserve='ownership' * "${pkgdir}"/usr/share/lxqt/themes/${_pkgname}
+ mv "${pkgdir}"/usr/share/lxqt/themes/"${_pkgname}"/Sand.colors "${pkgdir}"/usr/share/color-schemes
+ mv "${pkgdir}"/usr/share/lxqt/themes/"${_pkgname}"/Sand.colorscheme "${pkgdir}"/usr/share/qtermwidget5/color-schemes/
+
+}