summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStar Brilliant2015-06-16 02:46:47 +0800
committerStar Brilliant2015-06-16 02:46:47 +0800
commit68d7e2977515bed2500b6588acaaee5963f4f87f (patch)
treed211805604d47ed7bf65deec3e2aece3e56a45e2
downloadaur-68d7e2977515bed2500b6588acaaee5963f4f87f.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cd2061ab4d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sandbox
+ pkgdesc = sandbox'd LD_PRELOAD hack
+ pkgver = 2.6
+ pkgrel = 2
+ url = http://www.gentoo.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://distfiles.gentoo.org/distfiles/sandbox-2.6.tar.xz
+ md5sums = 83c63d4959c0ebe89685b83f4bbd9f23
+
+pkgname = sandbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..449bac3728ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Barthalion <echo YXVyQGJwaW90cm93c2tpLnBsCg== | base64 -d>
+# Maintainer: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+pkgname=sandbox
+pkgver=2.6
+pkgrel=2
+pkgdesc="sandbox'd LD_PRELOAD hack"
+arch=('i686' 'x86_64')
+url='http://www.gentoo.org/'
+license=('GPL')
+depends=('glibc')
+source=(http://distfiles.gentoo.org/distfiles/$pkgname-$pkgver.tar.xz)
+md5sums=('83c63d4959c0ebe89685b83f4bbd9f23')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: