summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Strygin2021-10-03 22:17:04 +0300
committerNikita Strygin2021-10-03 22:19:14 +0300
commit55592554c1926502b7d057536996a39d8a7a8843 (patch)
treeb5f1675061095ea949f66369cee849882aa3c214
downloadaur-55592554c1926502b7d057536996a39d8a7a8843.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..895ec417f2f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = sandboxfs-bin
+ pkgdesc = A virtual file system for sandboxing
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/bazelbuild/sandboxfs
+ arch = x86_64
+ license = Apache
+ depends = fuse2
+ source = https://github.com/bazelbuild/sandboxfs/releases/download/sandboxfs-0.2.0/sandboxfs-0.2.0-20200420-linux-x86_64.tgz
+ sha256sums = 435645db70cd817e9b74a8235dcabbb0a575bbeccdf3af8238ac1dc8b27e7a54
+
+pkgname = sandboxfs-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51eda0e713ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Nikita Strygin <nikita6@bk.ru>
+pkgname=sandboxfs-bin
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A virtual file system for sandboxing "
+arch=(x86_64)
+url="https://github.com/bazelbuild/sandboxfs"
+license=('Apache')
+depends=(fuse2)
+makedepends=()
+source=("https://github.com/bazelbuild/sandboxfs/releases/download/sandboxfs-0.2.0/sandboxfs-0.2.0-20200420-linux-x86_64.tgz")
+sha256sums=("435645db70cd817e9b74a8235dcabbb0a575bbeccdf3af8238ac1dc8b27e7a54")
+
+build() {
+ # seems to contain only an uninstall script, which is not really needed for a package
+ rm -rf "${srcdir}"/libexec
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/"
+ cp -r "${srcdir}"/bin "${srcdir}"/share "$pkgdir/usr/"
+}