summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiretza2017-12-01 11:02:22 +0100
committerxiretza2017-12-01 11:02:22 +0100
commitb9c6a81e7760913c4fd950794b9184d33c9eabf8 (patch)
treeeb8f7564a3855460afef9803b8e0135b4d76b3da
parentc318c9dc57a8092ad281118c3d52e933ca0c9c90 (diff)
downloadaur-b9c6a81e7760913c4fd950794b9184d33c9eabf8.tar.gz
switch to rigred fork
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--sandsifter-git.patch24
3 files changed, 13 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fb29135b1c1..7a91126df2a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sandsifter-git
pkgdesc = The x86 processor fuzzer
- pkgver = r1.dff6324
- pkgrel = 3
- url = https://github.com/xoreaxeaxeax/sandsifter
+ pkgver = r22.d0e9e8e
+ pkgrel = 1
+ url = https://github.com/rigred/sandsifter
arch = i686
arch = x86_64
license = unknown
@@ -10,10 +10,10 @@ pkgbase = sandsifter-git
depends = python2-capstone
provides = sandsifter
conflicts = sandsifter
- source = sandsifter::git+https://github.com/xoreaxeaxeax/sandsifter
+ source = sandsifter::git+https://github.com/rigred/sandsifter
source = sandsifter-git.patch
sha256sums = SKIP
- sha256sums = ee35e3e5d6a6c018e5a138af388d78d0dce3b1605b53ddfe1241cfdef9daa18a
+ sha256sums = fbe1e12694f8be31ab3128932c6a5e91950f14fd1c22196559dd74711b9d080f
pkgname = sandsifter-git
diff --git a/PKGBUILD b/PKGBUILD
index ee7c6e236976..1228cf0b0d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: xiretza <xiretza+aur@gmail.com>
_pkgname=sandsifter
pkgname="${_pkgname}-git"
-pkgver=r1.dff6324
-pkgrel=3
+pkgver=r22.d0e9e8e
+pkgrel=1
pkgdesc="The x86 processor fuzzer"
arch=("i686" "x86_64")
-url="https://github.com/xoreaxeaxeax/${_pkgname}"
+url="https://github.com/rigred/${_pkgname}"
# see https://github.com/xoreaxeaxeax/sandsifter/issues/13
license=("unknown")
groups=()
@@ -16,7 +16,7 @@ conflicts=("${_pkgname}")
source=("${_pkgname}::git+${url}"
"${pkgname}.patch")
sha256sums=('SKIP'
- 'ee35e3e5d6a6c018e5a138af388d78d0dce3b1605b53ddfe1241cfdef9daa18a')
+ 'fbe1e12694f8be31ab3128932c6a5e91950f14fd1c22196559dd74711b9d080f')
pkgver() {
cd "$srcdir/${_pkgname}"
diff --git a/sandsifter-git.patch b/sandsifter-git.patch
index 305a8869a0dc..0b8087b03511 100644
--- a/sandsifter-git.patch
+++ b/sandsifter-git.patch
@@ -1,16 +1,10 @@
diff --git a/sifter.py b/sifter.py
-index 856b607..47d2d88 100755
+index fa28f93..803c59a 100755
--- a/sifter.py
+++ b/sifter.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/env python2
-
- # instruction injector frontend
-
-@@ -27,10 +27,10 @@ import code
- import copy
- from ctypes import *
+@@ -33,10 +33,10 @@ try:
+ except NameError:
+ raw_input = input # Python 3
-INJECTOR = "./injector"
+INJECTOR = "/opt/sandsifter/injector"
@@ -21,13 +15,3 @@ index 856b607..47d2d88 100755
LOG = OUTPUT + "log"
SYNC = OUTPUT + "sync"
TICK = OUTPUT + "tick"
-diff --git a/summarize.py b/summarize.py
-index 44d524f..014b58d 100755
---- a/summarize.py
-+++ b/summarize.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/env python2
-
- # we had a much more automated and intelligent approach to reducing the log, but
- # could not come up with a reasonable way to differentiate between a modr/m byte