summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-05-31 16:15:14 +0200
committerMartin T. H. Sandsmark2020-05-31 16:15:14 +0200
commitf45a6e0b92dd1d113acad09cd4d20aac19ba6699 (patch)
tree5d305714df619243e39554ecc0e5a787f0b389ae
downloadaur-f45a6e0b92dd1d113acad09cd4d20aac19ba6699.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcf0d996f899
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sandsmark-notificationd-git
+ pkgdesc = simple notification daemon because everything else sucks
+ pkgver = r16.7d33d87
+ pkgrel = 1
+ url = https://github.com/sandsmark/sandsmark-notificationd
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ provides = sandsmark-notificationd
+ conflicts = sandsmark-notificationd
+ source = git+https://github.com/sandsmark/sandsmark-notificationd.git
+ md5sums = SKIP
+
+pkgname = sandsmark-notificationd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c207a22a461c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=sandsmark-notificationd-git
+pkgver=r16.7d33d87
+pkgrel=1
+pkgdesc="simple notification daemon because everything else sucks"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/sandsmark-notificationd"
+license=(GPL3)
+depends=(qt5-base)
+makedepends=(git)
+provides=(sandsmark-notificationd)
+conflicts=(sandsmark-notificationd)
+source=('git+https://github.com/sandsmark/sandsmark-notificationd.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd sandsmark-notificationd
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../sandsmark-notificationd \
+ -DCMAKE_BUILD_TYPE=Debug \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}