summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-05-12 14:16:01 +0200
committerMartin T. H. Sandsmark2020-05-12 14:16:01 +0200
commit83fb84554626843f41c7dedc90d95767fb198f6d (patch)
tree46aec8f7bbf86b81653074efef442e8937f66326
downloadaur-83fb84554626843f41c7dedc90d95767fb198f6d.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee6021271502
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sandsmark-screenshot-git
+ pkgdesc = Trivial application to take screenshots and put them on the clipboard
+ pkgver = 5.e2fc792
+ pkgrel = 1
+ url = https://github.com/sandsmark/sandsmark-screenshot
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ provides = sandsmark-screenshot
+ conflicts = sandsmark-screenshot
+ source = git+https://github.com/sandsmark/sandsmark-screenshot.git
+ sha256sums = SKIP
+
+pkgname = sandsmark-screenshot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3da8221eb7a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=sandsmark-screenshot-git
+pkgver=5.e2fc792
+pkgrel=1
+pkgdesc="Trivial application to take screenshots and put them on the clipboard"
+arch=('x86_64')
+url='https://github.com/sandsmark/sandsmark-screenshot'
+license=('GPL')
+depends=( 'qt5-base')
+makedepends=('git')
+provides=('sandsmark-screenshot')
+conflicts=('sandsmark-screenshot')
+source=('git+https://github.com/sandsmark/sandsmark-screenshot.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd sandsmark-screenshot
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+prepare() {
+ mkdir -p build
+ cd build
+ qmake ../sandsmark-screenshot
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ install -Dm755 build/screenshot "${pkgdir}/usr/bin/screenshot"
+}