summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-11-25 09:23:38 +0100
committerMartin T. H. Sandsmark2020-11-25 09:23:38 +0100
commitc25b0a6d450cbfaead2cde9aafe6d7e5152989a7 (patch)
tree0872f670ce8bf65045799def334e930a5ac5fe9c
downloadaur-c25b0a6d450cbfaead2cde9aafe6d7e5152989a7.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c0f9447a781
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sandsmark-xdg-autostart-launcher-git
+ pkgdesc = Minimalistic (315 lines of code, no dependencies) XDG compliant autostart launcher
+ pkgver = 10.f5b5758
+ pkgrel = 1
+ url = https://github.com/sandsmark/xdg-autostart-launcher
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ provides = sandsmark-xdg-autostart-launcher
+ provides = xdg-autostart-launcher
+ conflicts = sandsmark-xdg-autostart-launcher
+ conflicts = xdg-autostart-launcher
+ source = git+https://github.com/sandsmark/xdg-autostart-launcher.git
+ md5sums = SKIP
+
+pkgname = sandsmark-xdg-autostart-launcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541c43582619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=sandsmark-xdg-autostart-launcher-git
+pkgver=10.f5b5758
+pkgrel=1
+pkgdesc="Minimalistic (315 lines of code, no dependencies) XDG compliant autostart launcher"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/xdg-autostart-launcher"
+license=(GPL3)
+depends=(gcc-libs)
+makedepends=(git cmake)
+provides=(sandsmark-xdg-autostart-launcher xdg-autostart-launcher)
+conflicts=(sandsmark-xdg-autostart-launcher xdg-autostart-launcher)
+source=('git+https://github.com/sandsmark/xdg-autostart-launcher.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd xdg-autostart-launcher
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../xdg-autostart-launcher \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}