summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2024-02-04 18:32:48 +0100
committerRicardo (XenGi) Band2024-02-04 18:32:48 +0100
commit0b8f07f9f20fe739ac8ae1192e8261d8b2007665 (patch)
tree01663e2941d8816f285f1615fa7df23a3357d420
parent9138a1ac267d6fddb31112149c5f9515b86ce220 (diff)
downloadaur-sanic.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore96
-rw-r--r--PKGBUILD25
3 files changed, 109 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6073385dc3ba..d42ba1536724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = sanic
- pkgdesc = An all-in-one tool to develop, build, and deploy your Docker/Kubernetes projects
- pkgver = 1.3.1
+ pkgdesc = chaos music control
+ pkgver = 0.0.1
pkgrel = 1
- url = https://github.com/distributed-containers-inc/sanic
- arch = x86_64
- license = Apache
+ url = https://git.berlin.ccc.de/cccb/sanic
+ arch = any
+ license = MIT
makedepends = go
- depends = kubectl
- depends = docker
- source = sanic-1.3.1.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v1.3.1.tar.gz
- sha256sums = ae1caac5428327ccc85aca42953178c4ce20ed6ce5fa250a2d47a71ab7eb3d92
+ source = sanic-0.0.1.tar.gz::https://git.berlin.ccc.de/cccb/sanic/src/tag/v0.0.1.tar.gz
+ sha256sums = foo
pkgname = sanic
-
diff --git a/.gitignore b/.gitignore
index 75b2db5613dd..f963c25e7d63 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,91 @@
-*.tar.gz
-*.xz
-*.tar.bz2
-src
-pkg
+# Created by https://www.toptal.com/developers/gitignore/api/linux,windows,macos,archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=linux,windows,macos,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+
+### macOS ###
+# General
+.DS_Store
+.AppleDouble
+.LSOverride
+
+# Icon must end with two \r
+Icon
+
+# Thumbnails
+._*
+
+# Files that might appear in the root of a volume
+.DocumentRevisions-V100
+.fseventsd
+.Spotlight-V100
+.TemporaryItems
+.Trashes
+.VolumeIcon.icns
+.com.apple.timemachine.donotpresent
+
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
+
+### macOS Patch ###
+# iCloud generated files
+*.icloud
+
+### Windows ###
+# Windows thumbnail cache files
+Thumbs.db
+Thumbs.db:encryptable
+ehthumbs.db
+ehthumbs_vista.db
+
+# Dump file
+*.stackdump
+
+# Folder config file
+[Dd]esktop.ini
+
+# Recycle Bin used on file shares
+$RECYCLE.BIN/
+
+# Windows Installer files
+*.cab
+*.msix
+*.msm
+*.msp
+
+# Windows shortcuts
+*.lnk
+
+# End of https://www.toptal.com/developers/gitignore/api/linux,windows,macos,archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
index e51163385ec6..e2a9e0e27a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,20 @@
-# Maintainer: David Birks <david@tellus.space>
+# Maintainer: Ricardo Band <email@ricardo.band>
+# Maintainer: coon <coon@mailbox.org>
pkgname=sanic
-pkgdesc='An all-in-one tool to develop, build, and deploy your Docker/Kubernetes projects'
-pkgver=1.3.1
+pkgdesc="chaos music control"
+pkgver=0.0.1
pkgrel=1
-arch=('x86_64')
-license=('Apache')
-url='https://github.com/distributed-containers-inc/sanic'
-depends=('kubectl' 'docker')
-makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v$pkgver.tar.gz")
-sha256sums=('ae1caac5428327ccc85aca42953178c4ce20ed6ce5fa250a2d47a71ab7eb3d92')
+arch=("any")
+license=("MIT")
+url="https://git.berlin.ccc.de/cccb/sanic"
+makedepends=("go")
+source=("$pkgname-$pkgver.tar.gz::https://git.berlin.ccc.de/cccb/sanic/src/tag/v$pkgver.tar.gz")
+sha256sums=('foo')
build() {
- # Trim PWD from binary
- export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
-
cd $pkgname-$pkgver
- go build --ldflags "-X main.version=$pkgver" .
+ go build .
}
package() {