summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-07-15 23:40:02 -0400
committerDavid Birks2019-07-15 23:40:02 -0400
commitbb08e1ed48a055cd98936dace62b0ecb4beac97a (patch)
treebaa652adc5aab29272ebecaae494863ca084a9ce
parent426bfd4b5a4228de60a6b85de966ffcaed9cefc7 (diff)
downloadaur-bb08e1ed48a055cd98936dace62b0ecb4beac97a.tar.gz
Update to 1.2.13
And add a ldflag for the version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b4a8576a713..1fa450d1a317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sanic
pkgdesc = An all-in-one tool to develop, build, and deploy your Docker/Kubernetes projects
- pkgver = 1.2.11
+ pkgver = 1.2.13
pkgrel = 1
url = https://github.com/distributed-containers-inc/sanic
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = sanic
makedepends = go
depends = kubectl
depends = docker
- source = sanic-1.2.11.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v1.2.11.tar.gz
- sha256sums = 2bf562a0335514e268b09b43ea7d65ecde54c815571589907557023d70799b70
+ source = sanic-1.2.13.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v1.2.13.tar.gz
+ sha256sums = ffb3eb245351239ecc1b4b13e208d35244540cfbcdf6735cbf86059ab9b1526b
pkgname = sanic
diff --git a/PKGBUILD b/PKGBUILD
index 3e4118b5a3a8..2ec4ac0afe87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sanic
pkgdesc='An all-in-one tool to develop, build, and deploy your Docker/Kubernetes projects'
-pkgver=1.2.11
+pkgver=1.2.13
pkgrel=1
arch=('x86_64')
license=('Apache')
@@ -10,24 +10,16 @@ url='https://github.com/distributed-containers-inc/sanic'
depends=('kubectl' 'docker')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v$pkgver.tar.gz")
-sha256sums=('2bf562a0335514e268b09b43ea7d65ecde54c815571589907557023d70799b70')
-
-prepare() {
- # Make fake gopath
- mkdir -p gopath/src/github.com/distributed-containers-inc
- ln -rTsf $pkgname-$pkgver gopath/src/github.com/distributed-containers-inc/sanic
-}
+sha256sums=('ffb3eb245351239ecc1b4b13e208d35244540cfbcdf6735cbf86059ab9b1526b')
build() {
# Trim PWD from binary
export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
- export GOPATH="$srcdir"/gopath
- export GO111MODULE=on
- cd gopath/src/github.com/distributed-containers-inc/sanic
- go install
+ cd $pkgname-$pkgver
+ go build --ldflags "-X main.version=$pkgver" .
}
package() {
- install -Dm 755 "$srcdir/gopath/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
}