summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSterophonick2024-04-09 18:06:21 -0600
committerSterophonick2024-04-09 18:06:21 -0600
commit2ba8f704663d10129f98fdbf18cd56ec8f3be930 (patch)
tree2929085c23745e89751cd0d8784eda13d84e9b93
parent8d9abf9809c5fb40ae33bd4e297ca41f0e1f4b7d (diff)
downloadaur-2ba8f704663d10129f98fdbf18cd56ec8f3be930.tar.gz
add --help
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xsappy200624
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78ebac665e16..5dec766334de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sappy2006
pkgdesc = MusicPlayer2000 music and sound player and editor
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
arch = x86_64
arch = i686
makedepends = p7zip
diff --git a/PKGBUILD b/PKGBUILD
index 0141ebe19100..b03a113701b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sappy2006
_pkgname='sappy2006'
pkgver=1.2
-pkgrel=1
+pkgrel=2
pkgdesc='MusicPlayer2000 music and sound player and editor'
arch=(x86_64 i686)
depends=('wine' 'winetricks')
diff --git a/sappy2006 b/sappy2006
index d9e173b2b6af..20cd912c8cf2 100755
--- a/sappy2006
+++ b/sappy2006
@@ -4,8 +4,8 @@
# TODO: report crash bugs for mod 17.1 and update package
export WINEPREFIX=~/.sappy2006
-export SAVEFILE=~/.sappy2006/savefile
-export SAPPYDIR=/usr/share/sappy2006
+export SAVEFILE=$WINEPREFIX/savefile
+export SAPPYDIR=/usr/share/sappy2006 # installation dir for AUR package
# configure all dlls
configure() {
@@ -18,13 +18,27 @@ configure() {
touch $SAVEFILE # ensures that we don't repeat configuration process
}
-if [ ! -f "$SAVEFILE" ]; then # first boot
- configure
-elif [ "$1" = "--mkpfx" ]; then # Force reconfigure prefix
+if [ "$1" = "--mkpfx" ]; then # Force reconfigure prefix
configure
elif [ "$1" = "--erase" ]; then # delete all data in prefix
rm -rf $WINEPREFIX
exit 0
+elif [ "$1" = "--help" ]; then # show command info
+ cat << EOF
+Sappy2006 Linux Loader by Atapi/Sterophonick
+Original Program: (c) 2006 Kawa and DJ ßouché
+
+Usage:
+ sappy2006 [--mkpfx] [--erase] [--help]
+
+ --mkpfx: Re-configure WINE prefix
+ --erase: Erase all data in WINE prefix
+ --help: Show this screen
+
+EOF
+ exit 0
+elif [ ! -f "$SAVEFILE" ]; then # first boot
+ configure
else
echo ""
fi