summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSterophonick2024-04-05 13:57:18 -0600
committerSterophonick2024-04-05 13:57:18 -0600
commit44c3771d9d3ce608919223ad0bdf80db8d713195 (patch)
tree4ebf37853429c1bff3c9a0119c01f3cf200e3849
downloadaur-44c3771d9d3ce608919223ad0bdf80db8d713195.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
-rw-r--r--mod17.zipbin0 -> 394243 bytes
-rwxr-xr-xsappy200632
-rw-r--r--sappy2006.desktop10
-rw-r--r--sappy2006.pngbin0 -> 2362 bytes
6 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36e681905301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sappy2006
+ pkgdesc = MusicPlayer2000 music and sound player and editor
+ pkgver = 1.2
+ pkgrel = 1
+ arch = x86_64
+ arch = i686
+ makedepends = p7zip
+ depends = wine winetricks
+ source = https://archive.org/download/installateur-sappy/Installateur_Sappy.exe
+ mod17.zip
+ source = sappy2006
+ source = sappy2006.desktop
+ source = sappy2006.png
+
+pkgname = sappy2006
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e947a27613e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sterophonick
+pkgname=sappy2006
+_pkgname='sappy2006'
+pkgver=1.2
+pkgrel=1
+pkgdesc='MusicPlayer2000 music and sound player and editor'
+arch=(x86_64 i686)
+depends=('wine' 'winetricks')
+makedepends=('p7zip')
+source=(https://archive.org/download/installateur-sappy/Installateur_Sappy.exe
+ mod17.zip # TODO: wait for wine to fix its funniness
+ sappy2006
+ sappy2006.desktop
+ sappy2006.png)
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+noextract=(mod17.rar)
+
+prepare() {
+ cd $srcdir
+ mkdir -p installer
+ 7z x Installateur_Sappy.exe -aou -oinstaller
+
+ # work around nsis quirk where registerd dll/ocx do weird things
+ cd installer
+ mv \$R0 fmod.dll # f51a7dd4d040a9c079cf64d36f569673
+ mv \$R0_1 timermm.dll # d0351cbb8d3a946bde5f43fc6ca8086
+ mv \$R0_2 vbalCbEx6.ocx # 0e1135954bb1dbd1b3bb91ce7667ade2
+ mv \$R0_3 vbalExpBar6.ocx # e73792847f2bbb41e79cd31afd20926e
+ mv \$R0_4 cPopMenu6.ocx # 4219192acf00a39f10f6e76439290580
+ mv \$R0_5 SSubTmr6.dll # dc7a3bc0fc185cd68848dc6f7d7b026b
+
+}
+
+package() {
+ install -Dm755 sappy2006 $pkgdir/usr/bin/sappy2006
+ install -Dm644 sappy2006.desktop $pkgdir/usr/share/applications/sappy2006.desktop
+ install -Dm644 sappy2006.png $pkgdir/usr/share/pixmaps/sappy2006.png
+
+ mkdir -p $pkgdir/usr/share/sappy2006
+
+ cp -r $srcdir/installer/* $pkgdir/usr/share/sappy2006
+ chmod -R 777 $pkgdir/usr/share/sappy2006
+}
diff --git a/mod17.zip b/mod17.zip
new file mode 100644
index 000000000000..367e82580535
--- /dev/null
+++ b/mod17.zip
Binary files differ
diff --git a/sappy2006 b/sappy2006
new file mode 100755
index 000000000000..d9e173b2b6af
--- /dev/null
+++ b/sappy2006
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+# WINE Launcher script for Sappy 2006 :3
+# TODO: report crash bugs for mod 17.1 and update package
+
+export WINEPREFIX=~/.sappy2006
+export SAVEFILE=~/.sappy2006/savefile
+export SAPPYDIR=/usr/share/sappy2006
+
+# configure all dlls
+configure() {
+ winetricks -q vb6run
+ wine regsvr32 /s $SAPPYDIR/SSubTmr6.dll
+ wine regsvr32 /s $SAPPYDIR/cPopMenu6.ocx
+ wine regsvr32 /s $SAPPYDIR/timermm.dll
+ wine regsvr32 /s $SAPPYDIR/vbalCbEx6.ocx
+ wine regsvr32 /s $SAPPYDIR/vbalExpBar6.ocx
+ touch $SAVEFILE # ensures that we don't repeat configuration process
+}
+
+if [ ! -f "$SAVEFILE" ]; then # first boot
+ configure
+elif [ "$1" = "--mkpfx" ]; then # Force reconfigure prefix
+ configure
+elif [ "$1" = "--erase" ]; then # delete all data in prefix
+ rm -rf $WINEPREFIX
+ exit 0
+else
+ echo ""
+fi
+
+wine $SAPPYDIR/sappy.exe
diff --git a/sappy2006.desktop b/sappy2006.desktop
new file mode 100644
index 000000000000..63a91afa4299
--- /dev/null
+++ b/sappy2006.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Sappy 2006
+Comment=MusicPlayer2000 music and sound player and editor
+Exec=sappy2006
+Icon=sappy2006
+Terminal=false
+StartupNotify=false
+Categories=Wine;AudioVideo;
diff --git a/sappy2006.png b/sappy2006.png
new file mode 100644
index 000000000000..f889867e6b43
--- /dev/null
+++ b/sappy2006.png
Binary files differ