summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-07-13 19:27:16 +0200
committerErik Dubois2017-07-13 19:27:16 +0200
commit833dd8c03cc572ada74f3223fb8131d9a486560f (patch)
tree79b22591c75ae9545c207213358830bfb5743b26
downloadaur-833dd8c03cc572ada74f3223fb8131d9a486560f.tar.gz
commit from @ Thu Jul 13 19:27:16 CEST 2017
-rwxr-xr-x.Changelog1
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xgit.sh16
4 files changed, 64 insertions, 0 deletions
diff --git a/.Changelog b/.Changelog
new file mode 100755
index 000000000000..22f3e0b06faf
--- /dev/null
+++ b/.Changelog
@@ -0,0 +1 @@
+f84c8517f5b490f9480c8f970d6f286b8141c894
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03aa776fdce8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jul 13 17:27:16 UTC 2017
+pkgbase = sardi-colora-variations-icons-git
+ pkgdesc = Sardi is an icon collection for any linux distro with 6 different circular icons and 10 different kind of folders. With scripts you can change the colours of the Sardi icons
+ pkgver = 9.3
+ pkgrel = 0
+ arch = any
+ license = Attribution-NonCommercial-ShareAlike 4.0 International Public License
+ makedepends = git
+ provides = sardi-colora-variations-icons-git
+ conflicts = sardi-colora-variations-icons-git
+ options = !strip
+ options = !emptydirs
+ source = sardi-colora-variations-icons::git+https://github.com/erikdubois/Sardi-Colora-Variations
+ sha256sums = SKIP
+
+pkgname = sardi-colora-variations-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..16169ad623f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Erik Dubois <erik.dubois@gmail.com>
+pkgname=sardi-colora-variations-icons-git
+_pkgname=sardi-colora-variations-icons
+_destname="/usr/share/icons/"
+_pkggithub="https://github.com/erikdubois/Sardi-Colora-Variations"
+pkgdesc="Sardi is an icon collection for any linux distro with 6 different circular icons and 10 different kind of folders. With scripts you can change the colours of the Sardi icons "
+pkgver=9.3
+pkgrel=0
+arch=('any')
+url="${pkggithub}"
+license=('Attribution-NonCommercial-ShareAlike 4.0 International Public License')
+makedepends=('git')
+#depends=('sardi-icons')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+options=(!strip !emptydirs)
+source=("${_pkgname}"::git+"${_pkggithub}")
+sha256sums=('SKIP')
+
+
+package() {
+ rm -f "${srcdir}/${_pkgname}/"README.md
+ rm -f "${srcdir}/${_pkgname}/"git-v*
+ rm -f "${srcdir}/${_pkgname}/"setup*
+ install -dm 755 "${pkgdir}"/"${_destname}"
+ cp -dr --no-preserve='ownership' ${_pkgname}/* "${pkgdir}"/usr/share/icons/
+}
+
+
diff --git a/git.sh b/git.sh
new file mode 100755
index 000000000000..275cdf15587c
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+############################################################################
+# Author : Erik Dubois
+# Website : http://www.erikdubois.be
+############################################################################
+
+
+mksrcinfo
+git add --all .
+
+# Committing to the local repository with a message containing the time details
+curtime=$(date)
+git commit -m "commit from @ $curtime"
+
+# Push the local snapshot to a remote destination
+git push -u origin master \ No newline at end of file