summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-07-15 12:40:23 +0200
committerErik Dubois2017-07-15 12:40:23 +0200
commit247c481e5b77bd04006fcf6348b9a7553242afcc (patch)
tree310281d6ba3a5e3caa93e2de395fb2229df49549
downloadaur-247c481e5b77bd04006fcf6348b9a7553242afcc.tar.gz
commit from @ Sat Jul 15 12:40:23 CEST 2017
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xgit.sh16
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10a545901eaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jul 15 10:40:23 UTC 2017
+pkgbase = sardi-ghost-flexible-mixing-icons-git
+ pkgdesc = The Sardi icon set contains 80+ scripts to change from colour. Change it yourself with these scripts.
+ pkgver = 9.3
+ pkgrel = 0
+ arch = any
+ license = Attribution-NonCommercial-ShareAlike 4.0 International Public License
+ makedepends = git
+ provides = sardi-ghost-flexible-mixing-icons-git
+ conflicts = sardi-ghost-flexible-mixing-icons-git
+ options = !strip
+ options = !emptydirs
+ source = sardi-ghost-flexible-mixing-icons::git+https://github.com/erikdubois/Sardi-Ghost-Flexible-Mixing
+ sha256sums = SKIP
+
+pkgname = sardi-ghost-flexible-mixing-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..fc4b4be1dab4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Erik Dubois <erik.dubois@gmail.com>
+pkgname=sardi-ghost-flexible-mixing-icons-git
+_pkgname=sardi-ghost-flexible-mixing-icons
+_destname="/usr/share/icons/"
+_pkggithub="https://github.com/erikdubois/Sardi-Ghost-Flexible-Mixing"
+pkgdesc="The Sardi icon set contains 80+ scripts to change from colour. Change it yourself with these scripts."
+pkgver=9.3
+pkgrel=0
+arch=('any')
+url="${pkggithub}"
+license=('Attribution-NonCommercial-ShareAlike 4.0 International Public License')
+makedepends=('git')
+#depends=('sardi-icons')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+options=(!strip !emptydirs)
+source=("${_pkgname}"::git+"${_pkggithub}")
+sha256sums=('SKIP')
+
+
+package() {
+ rm -f "${srcdir}/${_pkgname}/"README.md
+ rm -f "${srcdir}/${_pkgname}/"git-v*
+ rm -f "${srcdir}/${_pkgname}/"setup*
+ install -dm 755 "${pkgdir}"/"${_destname}"
+ cp -dr --no-preserve='ownership' ${_pkgname}/* "${pkgdir}"/usr/share/icons/
+}
+
+
diff --git a/git.sh b/git.sh
new file mode 100755
index 000000000000..275cdf15587c
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+############################################################################
+# Author : Erik Dubois
+# Website : http://www.erikdubois.be
+############################################################################
+
+
+mksrcinfo
+git add --all .
+
+# Committing to the local repository with a message containing the time details
+curtime=$(date)
+git commit -m "commit from @ $curtime"
+
+# Push the local snapshot to a remote destination
+git push -u origin master \ No newline at end of file