summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2019-02-22 09:43:28 +0100
committerErik Dubois2019-02-22 09:43:28 +0100
commitb1f4bef708a602e6e7cd67348b2553468cd5ff49 (patch)
tree3c290147f3eb608f248d3a96f09d99a3733817cc
downloadaur-b1f4bef708a602e6e7cd67348b2553468cd5ff49.tar.gz
first commit - mint-y icons with sardi mono icons
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..730868c8e542
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sardi-mono-mint-y-icons-git
+ pkgdesc = New icons from LinuxMint 18 inspired by the Moka icon set with sardi-mono as main icon set
+ pkgver = 357.1ce9f028
+ pkgrel = 1
+ url = https://github.com/linuxmint/mint-y-icons
+ arch = any
+ license = GPL3
+ depends = sardi-icons
+ provides = sardi-mono-mint-y-icons
+ conflicts = sardi-mono-mint-y-icons
+ source = sardi-mono-mint-y-icons::git+https://github.com/linuxmint/mint-y-icons.git
+ sha256sums = SKIP
+
+pkgname = sardi-mono-mint-y-icons-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..04eebdd9da58
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+git.sh \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33699f263bc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Maintainer: erik dubois <erik.dubois@gmail.com>
+pkgname=sardi-mono-mint-y-icons-git
+_pkgname=sardi-mono-mint-y-icons
+pkgver=357.1ce9f028
+pkgrel=1
+pkgdesc="New icons from LinuxMint 18 inspired by the Moka icon set with sardi-mono as main icon set"
+arch=('any')
+url="https://github.com/linuxmint/mint-y-icons"
+license=('GPL3')
+depends=('sardi-icons')
+makedepends=()
+optdepends=()
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}"::git+https://github.com/linuxmint/mint-y-icons.git)
+sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+package() {
+ cd ${srcdir}/${_pkgname}/usr/share/icons
+ rm -rf Mint-Y
+ find . -name "index.theme" -type f -exec sed -i "s/Name=Mint-Y-/Name=Sardi-Mono-Mint-Y-/g" {} \;
+ find . -name "index.theme" -type f -exec sed -i "s/Inherits=Mint-Y,Adwaita,gnome,hicolor/Inherits=Sardi-Mono,Sardi,Surfn,Adwaita,gnome,hicolor/g" {} \;
+ mv Mint-Y-Aqua Sardi-Mono-Mint-Y-Aqua
+ mv Mint-Y-Blue Sardi-Mono-Mint-Y-Blue
+ mv Mint-Y-Brown Sardi-Mono-Mint-Y-Brown
+ mv Mint-Y-Grey Sardi-Mono-Mint-Y-Grey
+ mv Mint-Y-Orange Sardi-Mono-Mint-Y-Orange
+ mv Mint-Y-Pink Sardi-Mono-Mint-Y-Pink
+ mv Mint-Y-Purple Sardi-Mono-Mint-Y-Purple
+ mv Mint-Y-Red Sardi-Mono-Mint-Y-Red
+ mv Mint-Y-Sand Sardi-Mono-Mint-Y-Sand
+ mv Mint-Y-Teal Sardi-Mono-Mint-Y-Teal
+ cd ${srcdir}/${_pkgname}
+ cp -aR ./usr ${pkgdir}
+}