summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-07-14 09:16:08 +0200
committerErik Dubois2017-07-14 09:16:08 +0200
commit91d0d6fe1e434341a5fd3b706c4bc2a9b354b665 (patch)
treecb7aa31326a619a25ed5eef1d8750e37c2ca0492
downloadaur-91d0d6fe1e434341a5fd3b706c4bc2a9b354b665.tar.gz
commit from @ Fri Jul 14 09:16:08 CEST 2017
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xgit.sh16
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77d9e0ed9702
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jul 14 07:16:08 UTC 2017
+pkgbase = sardi-orb-colora-variations-icons-git
+ pkgdesc = The Sardi icon set contains 80+ scripts to change from colour. Change it yourself with these scripts.
+ pkgver = 9.3
+ pkgrel = 0
+ arch = any
+ license = Attribution-NonCommercial-ShareAlike 4.0 International Public License
+ makedepends = git
+ provides = sardi-orb-colora-variations-icons-git
+ conflicts = sardi-orb-colora-variations-icons-git
+ options = !strip
+ options = !emptydirs
+ source = sardi-orb-colora-variations-icons::git+https://github.com/erikdubois/Sardi-Orb-Colora-Variations
+ sha256sums = SKIP
+
+pkgname = sardi-orb-colora-variations-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3b8e5df0c481
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Erik Dubois <erik.dubois@gmail.com>
+pkgname=sardi-orb-colora-variations-icons-git
+_pkgname=sardi-orb-colora-variations-icons
+_destname="/usr/share/icons/"
+_pkggithub="https://github.com/erikdubois/Sardi-Orb-Colora-Variations"
+pkgdesc="The Sardi icon set contains 80+ scripts to change from colour. Change it yourself with these scripts."
+pkgver=9.3
+pkgrel=0
+arch=('any')
+url="${pkggithub}"
+license=('Attribution-NonCommercial-ShareAlike 4.0 International Public License')
+makedepends=('git')
+#depends=('sardi-icons')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+options=(!strip !emptydirs)
+source=("${_pkgname}"::git+"${_pkggithub}")
+sha256sums=('SKIP')
+
+
+package() {
+ rm -f "${srcdir}/${_pkgname}/"README.md
+ rm -f "${srcdir}/${_pkgname}/"git-v*
+ rm -f "${srcdir}/${_pkgname}/"setup*
+ install -dm 755 "${pkgdir}"/"${_destname}"
+ cp -dr --no-preserve='ownership' ${_pkgname}/* "${pkgdir}"/usr/share/icons/
+}
+
+
diff --git a/git.sh b/git.sh
new file mode 100755
index 000000000000..275cdf15587c
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+############################################################################
+# Author : Erik Dubois
+# Website : http://www.erikdubois.be
+############################################################################
+
+
+mksrcinfo
+git add --all .
+
+# Committing to the local repository with a message containing the time details
+curtime=$(date)
+git commit -m "commit from @ $curtime"
+
+# Push the local snapshot to a remote destination
+git push -u origin master \ No newline at end of file