summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSur.en2022-04-30 21:56:08 +0400
committerSur.en2022-04-30 21:56:54 +0400
commit328b7cfc8fefba86e613e6abee45ae0bcecb5349 (patch)
treee14103a13d9fa7fcf2f4f32f8bab146bac4c5a29
parentda976eb6d48de23ee2e60b9050428005c8348bd8 (diff)
downloadaur-328b7cfc8fefba86e613e6abee45ae0bcecb5349.tar.gz
Completely change content of PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
2 files changed, 3 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 612ad6af0cbf..831f4b2d9185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,10 @@ pkgbase = sarqx-reporter
pkgdesc = CLI application.
pkgver = 0.0.1
pkgrel = 1
- url = https://gitlab.com/sarqx_group/sarqx-reporter
+ url = git@gitlab.com/sarqx_group/sarqx-reporter
arch = i686
arch = x86_64
license = GPL
- makedepends = git
- makedepends = make
- provides = sarqx-reporter=0.0.1
- conflicts = sarqx-reporter
sha256sums = SKIP
pkgname = sarqx-reporter
diff --git a/PKGBUILD b/PKGBUILD
index 345303a1bb36..dc27259a4823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,48 +5,10 @@ pkgver=0.0.1
pkgrel=1
pkgdesc="CLI application."
arch=(i686 x86_64)
-url=https://gitlab.com/sarqx_group/sarqx-reporter
+url="git@gitlab.com/sarqx_group/sarqx-reporter"
license=('GPL')
-makedepends=(git make)
-provides=($pkgname=$pkgver)
-conflicts=($pkgname)
sha256sums=('SKIP')
-prepare() {
- git clone git@gitlab.com:sarqx_group/sarqx-reporter.git
-}
-
-build() {
- cd $pkgname
-
- make install
-}
-
package() {
- cd $pkgname
-
- mkdir -p $pkgdir/opt/$pkgname/share/licenses
- install -Dm644 LICENSE $pkgdir/opt/$pkgname/share/licenses
-
- # TODO: maybe I should change permission of bin files
- mkdir -p $pkgdir/opt/$pkgname/bin
- install -Dm755 $pkgname $pkgdir/opt/$pkgname/bin
- install -Dm755 askpass.sh $pkgdir/opt/$pkgname/bin
-
- mkdir -p $pkgdir/usr/bin/
- ln -s /opt/$pkgname/bin/$pkgname $pkgdir/usr/bin/$pkgname
-
- mkdir -p $pkgdir/var/opt/$pkgname/logs
- # HELP: chmod 600 provides read and write permission for user
- chmod 644 $pkgdir/var/opt/$pkgname/logs
-
- # HELP: store config files
- mkdir -p $pkgdir/etc/opt/$pkgname
- chmod 600 $pkgdir/etc/opt/$pkgname
-
- # Create daemon file and give its name
- systemd_file_name=$(make create_systemd)
-
- mkdir -p $pkgdir/etc/systemd/system
- install -Dm644 $systemd_file_name $pkgdir/etc/systemd/system
+ install -D -m755 "${srcdir}/${pkgname}-${pkgver}/${pkgname}.rb" "${pkgdir}/usr/bin/${pkgname}"
}