summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinz20082022-04-01 17:57:37 +0200
committerVinz20082022-04-01 17:57:37 +0200
commit083d54de596f3ef4fec79529efaabf3fe3f1569e (patch)
treecca291572a4e6b1ed6f5376c9eaedff513dc0f8a
downloadaur-083d54de596f3ef4fec79529efaabf3fe3f1569e.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96f62c276b1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sasm-asm-git
+ pkgdesc = A compiler of sasm, an assembly-like language that compile to assembly.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/Vinz2008/Sasm
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = nasm
+ source = sasm-asm::git+https://github.com/vinz2008/Sasm.git
+ sha256sums = SKIP
+
+pkgname = sasm-asm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b5f67ac0659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Vincent Bidard de la Noƫ vincentbidarddelanoe@gmail.com
+pkgname="sasm-asm-git"
+pkgver="0.2"
+pkgrel=1
+pkgdesc="A compiler of sasm, an assembly-like language that compile to assembly."
+arch=('any')
+url="https://github.com/Vinz2008/Sasm"
+license=('GPL')
+makedepends=("git")
+depends=("nasm")
+sha256sums=('SKIP')
+install=
+changelog=
+source=("sasm-asm::git+https://github.com/vinz2008/Sasm.git")
+noextract=()
+
+
+build() {
+ echo ${srcdir}
+ cd ${srcdir}/sasm-asm
+ make
+}
+
+check() {
+ cd ${srcdir}/sasm-asm
+ make test
+ ./sasm-tests
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/sasm-asm/sasm" "${pkgdir}/usr/bin/sasm"
+ chmod a+x "${pkgdir}/usr/bin/sasm"
+}