summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstah2018-04-04 00:26:48 +0200
committermuhviehstah2018-04-04 00:26:48 +0200
commitf47088e81ca1a568b37c36305480631bdf5049f8 (patch)
treee71bf35b492fb06181dadc2ecfaa455958ed70aa
parent966c4b305c1dfc6f6855a6ed14bac009369d0986 (diff)
downloadaur-f47088e81ca1a568b37c36305480631bdf5049f8.tar.gz
removed gcc5 makedepend and fix build
-rw-r--r--.SRCINFO5
-rw-r--r--1.patch12
-rw-r--r--PKGBUILD12
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f400c82b2e8..e9d916bccb43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = sasquatch
pkgdesc = Tools for squashfs, a highly compressed read-only filesystem for Linux.
pkgver = 4.3
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/devttys0/sasquatch
arch = i686
arch = x86_64
license = GPL
- makedepends = gcc5
depends = gzip
depends = zlib
depends = lzo
@@ -14,8 +13,10 @@ pkgbase = sasquatch
depends = lz4
source = git+https://github.com/devttys0/sasquatch
source = read_fragment_table_n_stack_overflow-fix.patch
+ source = 1.patch
sha256sums = SKIP
sha256sums = 120c2d208085129235bf998b1c22abee19db26120a98174b9beb5edd7b9c84e9
+ sha256sums = SKIP
pkgname = sasquatch
diff --git a/1.patch b/1.patch
new file mode 100644
index 000000000000..5d14a1d00b78
--- /dev/null
+++ b/1.patch
@@ -0,0 +1,12 @@
+--- unsquashfs.c
++++ unsquashfs.c
+@@ -32,8 +32,8 @@
+ #include "stdarg.h"
+
+ #include <sys/sysinfo.h>
+-#include <sys/types.h>
+ #include <sys/time.h>
++#include <sys/sysmacros.h>
+ #include <sys/resource.h>
+ #include <limits.h>
+ #include <ctype.h>
diff --git a/PKGBUILD b/PKGBUILD
index c17938106327..c741a76f04ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,17 @@
pkgname=sasquatch
_origpkgname=squashfs-tools
pkgver=4.3
-pkgrel=6
+pkgrel=7
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="https://github.com/devttys0/sasquatch"
license=("GPL")
arch=('i686' 'x86_64')
depends=('gzip' 'zlib' 'lzo' 'xz' 'lz4')
-makedepends=('gcc5')
source=('git+https://github.com/devttys0/sasquatch'
- 'read_fragment_table_n_stack_overflow-fix.patch')
+ 'read_fragment_table_n_stack_overflow-fix.patch'
+ '1.patch')
sha256sums=('SKIP'
- '120c2d208085129235bf998b1c22abee19db26120a98174b9beb5edd7b9c84e9')
+ '120c2d208085129235bf998b1c22abee19db26120a98174b9beb5edd7b9c84e9' 'SKIP')
build() {
cd ${srcdir}/sasquatch/
@@ -25,11 +25,9 @@ build() {
cd squashfs4.3
patch -p0 < ../patches/patch0.txt
cd squashfs-tools
+ patch -p0 < ${srcdir}/1.patch
patch -p0 -i "${srcdir}/read_fragment_table_n_stack_overflow-fix.patch"
- export CC=gcc-5
- export CXX=g++-5
make
- # INSTALL_DIR="${pkgdir}"/usr/bin CC=gcc-4.9 make -j5
}
package() {