summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-01-30 20:54:45 +0800
committerChocobo12019-01-30 21:04:11 +0800
commit9c8f8a575148e95dde05bd2daf31d2f8ed89e192 (patch)
treec0f730e3979beb4cb4a7f3f99f7bd7706e2d7e01
downloadaur-9c8f8a575148e95dde05bd2daf31d2f8ed89e192.tar.gz
newpkg: sassc-git 3.4.8.r9.g59aec3b-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b302fb22c4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sassc-git
+ pkgdesc = Libsass command line driver
+ pkgver = 3.4.8.r9.g59aec3b
+ pkgrel = 1
+ url = https://github.com/sass/sassc
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ depends = libsass
+ provides = sassc
+ conflicts = sassc
+ source = git+https://github.com/sass/sassc.git
+ sha256sums = SKIP
+
+pkgname = sassc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c16a356790b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=sassc-git
+pkgver=3.4.8.r9.g59aec3b
+pkgrel=1
+pkgdesc="Libsass command line driver"
+arch=('i686' 'x86_64')
+url="https://github.com/sass/sassc"
+license=('MIT')
+depends=('glibc' 'libsass')
+makedepends=('git')
+provides=('sassc')
+conflicts=('sassc')
+source=("git+https://github.com/sass/sassc.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "sassc"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "sassc"
+
+ autoreconf -fi
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "sassc"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/sassc/LICENSE"
+}