summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Wacha2022-06-02 15:57:42 +0200
committerAndrás Wacha2022-06-02 15:57:42 +0200
commit996fa95feb86a592f2cf709983c1ae683e84c57a (patch)
treeeb451bda14240e59c15782604a557f94a4c03083
parenta7762d45aea8a30ab941c8555dec3d2d33c464f9 (diff)
downloadaur-996fa95feb86a592f2cf709983c1ae683e84c57a.tar.gz
Tidying up dependencies, making check() work
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78a6b32fc0fb..5330b22e7c32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,7 @@
pkgbase = sasview
+ pkgdesc = Small-Angle Scattering Analysis
pkgver = 5.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://sasview.org
arch = x86_64
license = BSD
@@ -14,7 +15,6 @@ pkgbase = sasview
depends = python-pillow
depends = python-pylint
depends = python-periodictable
- depends = python-bumps
depends = python-numpy
depends = python-scipy
depends = python-pyqt5
@@ -23,8 +23,7 @@ pkgbase = sasview
depends = python-sphinx
depends = python-pyopencl
depends = python-ipykernel
- depends = ipython
- depends = jupyter
+ depends = python-qtconsole
depends = python-twisted
depends = python-qt5reactor
depends = python-service-identity
diff --git a/PKGBUILD b/PKGBUILD
index 81097b295735..42455c726ba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: András Wacha <awacha@gmail.com>
pkgname=sasview
pkgver=5.0.4
-pkgrel=1
-pkgdesc=""
+pkgrel=2
+pkgdesc="Small-Angle Scattering Analysis"
arch=(x86_64)
url="https://sasview.org"
license=('BSD')
@@ -15,7 +15,6 @@ depends=( python-setuptools
python-pillow
python-pylint
python-periodictable
- python-bumps
python-numpy
python-scipy
python-pyqt5
@@ -24,8 +23,7 @@ depends=( python-setuptools
python-sphinx
python-pyopencl
python-ipykernel
- ipython
- jupyter
+ python-qtconsole
python-twisted
python-qt5reactor
python-service-identity
@@ -44,10 +42,10 @@ build() {
python setup.py build_sphinx
}
-#check() {
-# cd "$pkgname-$pkgver"
-# python setup.py test
-#}
+check() {
+ cd "${pkgname}-${pkgver}/test"
+ python utest_sasview.py
+}
package() {
cd "$pkgname-$pkgver"