summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2018-05-26 11:18:22 +0200
committerjnanar2018-05-26 11:21:28 +0200
commita7fd042f13209dd3c5b033304833b82c8d2c7a28 (patch)
tree2a91d677d5fa51ab79502722adabddffac5fdde9
downloadaur-a7fd042f13209dd3c5b033304833b82c8d2c7a28.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00159e751f55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sat-cagou-hg
+ pkgver = r186.a826c70beda2
+ pkgrel = 1
+ arch = any
+ license = AGPL3
+ makedepends = git
+ depends = python2
+ depends = python2-kivy
+ depends = sat-xmpp-hg
+ depends = sat-templates-hg
+ depends = sat-tmp
+ depends = xsel
+ options = !emptydirs
+ source = hg+https://repos.goffi.org/cagou
+ md5sums = SKIP
+
+pkgname = sat-cagou-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96cd13d10bb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: jnanar <info [at] agayon [dot] be>
+
+pkgname=sat-cagou-hg
+pkgver=r186.a826c70beda2
+VERSION=0.7
+pkgrel=1
+pkgdesc=""
+arch=(any)
+url=""
+license=('AGPL3')
+depends=('python2' 'python2-kivy' 'sat-xmpp-hg' 'sat-templates-hg' 'sat-tmp' 'xsel')
+makedepends=('git')
+options=(!emptydirs)
+#optdepends=('')
+
+source=('hg+'https://repos.goffi.org/cagou)
+_hgname="cagou"
+
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$_hgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+
+package() {
+cd "$srcdir/$_hgname/"
+ # make sure UNICODE characters in the README are parsed correctly
+ export LC_CTYPE=en_US.utf-8
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}