summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2018-11-21 21:01:56 +0100
committerjnanar2018-11-21 21:01:56 +0100
commit1f3b2333d6dbca0d1c909811571b99e39855f51a (patch)
tree4d67b463d2f727a21b6f3c647adb3755ca9a6cb0
parent390c0de749d99686bcb6a4fa1c1b7942071d7ca7 (diff)
downloadaur-1f3b2333d6dbca0d1c909811571b99e39855f51a.tar.gz
Add sat and sat_frontends to a local tmp dir ton compile js. WIP
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b15fc093977..cf278f98f887 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,13 +39,13 @@ build() {
PYJSBUILD_PATH="$srcdir/pyjamas/bin/"
PATH=$PATH:$PYJSBUILD_PATH LIBERVIA_INSTALL=arch NO_PREINSTALL_OPT=nopreinstall SAT_INSTALL=nopreinstall python2 setup.py install --root="$srcdir/fakeinstall/" --prefix=/usr --optimize=1
# Compile pyjs
- mkdir -p html
- mkdir -p ../build/tmp_dir
- cp -r /usr/lib/python2.7/site-packages/sat_frontends/ build/tmp_dir
- cp -r /usr/lib/python2.7/site-packages/sat build/tmp_dir
- cd browser
- $PYJSBUILD_PATH/pyjsbuild libervia_main.py -d -I ../build/tmp_dir/ --no-compile-inplace -o ../html
- $PYJSBUILD_PATH/pyjsbuild libervia_test.py -d -I ../build/tmp_dir/ --no-compile-inplace -o ../html
+ mkdir -p $srcdir/$_realname/html
+ mkdir -p $srcdir/$_realname/build/tmp_dir
+ cp -r /usr/lib/python2.7/site-packages/sat_frontends $srcdir/$_realname/build/tmp_dir/sat_frontends
+ cp -r /usr/lib/python2.7/site-packages/sat $srcdir/$_realname/build/tmp_dir/sat
+ cd $srcdir/$_realname/browser
+ $PYJSBUILD_PATH/pyjsbuild libervia_main.py -d -I $srcdir/$_realname/build/tmp_dir/ --no-compile-inplace -o ../html
+ $PYJSBUILD_PATH/pyjsbuild libervia_test.py -d -I $srcdir/$_realname/build/tmp_dir/ --no-compile-inplace -o ../html
cp -r $srcdir/$_realname/{$_realname,browser,twisted} $srcdir/fakeinstall/usr/lib/python2.7/site-packages/libervia
}