summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2017-10-28 15:37:53 +0200
committerjnanar2017-10-28 15:44:41 +0200
commit18b7d23b52c6706ee1b63cfc00feaefd0584497b (patch)
treea432684a88236d4121f83959787999de139f7e83
downloadaur-18b7d23b52c6706ee1b63cfc00feaefd0584497b.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09e8c20dd117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sat-templates-hg
+ pkgver = 0.7.r54.a5dc14675d5e
+ pkgrel = 1
+ url = https://salut-a-toi.org/
+ arch = any
+ license = AGPL3
+ depends = python2
+ options = !strip
+ source = hg+https://repos.goffi.org/sat_templates
+ md5sums = SKIP
+
+pkgname = sat-templates-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..826e0b44bf75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Arnaud Joset <info [AT] agayon [DOT] be>
+
+pkgname=('sat-templates-hg')
+_realname=sat_templates
+pkgver=0.7.r54.a5dc14675d5e
+VERSION=0.7
+pkgrel=1
+url="https://salut-a-toi.org/"
+arch=('any')
+depends=('python2')
+makedepends=('')
+license=('AGPL3')
+source=("hg+https://repos.goffi.org/sat_templates")
+md5sums=('SKIP')
+options=('!strip')
+
+pkgver() {
+ cd "$_realname"
+ printf "$VERSION.r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+
+
+package_sat-templates(){
+ pkgdesc="sat-templates is a collection of templates for Salut à Toi, the multi-frontends multi-purposes XMPP client (core). For now, it needs to be accessible in the PYTHONPATH"
+ depends=('python2-jinja')
+
+ cd "$pkgdir"
+ install -dm755 "usr/lib/python2.7/site-packages/$_realname"
+ cd "$srcdir/$_realname"
+ cp -rv * "$pkgdir/usr/lib/python2.7/site-packages/$_realname"
+}
+