summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2018-06-21 20:44:34 +0200
committerjnanar2018-06-21 20:44:34 +0200
commit51e8fcd5b289ed45432626f4f3375cd8f103d15a (patch)
treefbdb9b2fd39875a3841af5bb6fc2caf12d408551
parent58b0ca41c98a7f24e120c235d7399fa2b61e4b53 (diff)
downloadaur-51e8fcd5b289ed45432626f4f3375cd8f103d15a.tar.gz
Actually-remove-the-fakeinstall-directory (Link Mauve)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d3ace03fe47..de05fd5e2176 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = sat-templates-hg
- pkgver = 0.7.r148.a4b6b8b6fc58
+ pkgdesc = sat-templates is a collection of templates for Salut à Toi, the multi-frontends multi-purposes XMPP client (core). For now, it needs to be accessible in the PYTHONPATH
+ pkgver = 0.7.r155.954759f0e8fa
pkgrel = 1
url = https://salut-a-toi.org/
arch = any
license = AGPL3
makedepends = mercurial
depends = python2
+ depends = python2-jinja
provides = sat-templates
conflicts = sat-templates
options = !strip
@@ -13,6 +15,4 @@ pkgbase = sat-templates-hg
md5sums = SKIP
pkgname = sat-templates-hg
- pkgdesc = sat-templates is a collection of templates for Salut à Toi, the multi-frontends multi-purposes XMPP client (core). For now, it needs to be accessible in the PYTHONPATH
- depends = python2-jinja
diff --git a/PKGBUILD b/PKGBUILD
index 33419964ccb1..01e266a843d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,14 @@
pkgname=('sat-templates-hg')
_realname=sat_templates
-pkgver=0.7.r149.e5ec33c4a8a8
+pkgver=0.7.r155.954759f0e8fa
_version=0.7
pkgrel=1
url="https://salut-a-toi.org/"
+pkgdesc="sat-templates is a collection of templates for Salut à Toi, the multi-frontends multi-purposes XMPP client (core). For now, it needs to be accessible in the PYTHONPATH"
+
arch=('any')
-depends=('python2')
+depends=('python2' 'python2-jinja')
makedepends=('mercurial')
conflicts=('sat-templates')
provides=('sat-templates')
@@ -24,14 +26,9 @@ pkgver() {
build() {
cd "$srcdir/$_realname"
python2 setup.py build
- python2 setup.py install --root="$srcdir/" --prefix=/usr --optimize=1
}
package(){
- pkgdesc="sat-templates is a collection of templates for Salut à Toi, the multi-frontends multi-purposes XMPP client (core). For now, it needs to be accessible in the PYTHONPATH"
- depends=('python2-jinja')
- cd "$pkgdir"
- install -dm755 "usr/lib/python2.7/site-packages/$_realname"
- cd "$srcdir/"
- mv -v "usr/lib/python2.7/site-packages/$_realname" "$pkgdir/usr/lib/python2.7/site-packages/"
+ cd "$srcdir/$_realname"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}